aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/telegramqml
diff options
context:
space:
mode:
authormadpilot <madpilot@FreeBSD.org>2016-06-19 06:10:55 +0800
committermadpilot <madpilot@FreeBSD.org>2016-06-19 06:10:55 +0800
commit56947902c3b266e4379aceab43d7f85c809cfeea (patch)
tree07b74ae37fded95881236e1b29c9317701b93d4c /net-im/telegramqml
parent67a73be8e72b0a3b06a1e38ce4d937239af9ca75 (diff)
downloadfreebsd-ports-gnome-56947902c3b266e4379aceab43d7f85c809cfeea.tar.gz
freebsd-ports-gnome-56947902c3b266e4379aceab43d7f85c809cfeea.tar.zst
freebsd-ports-gnome-56947902c3b266e4379aceab43d7f85c809cfeea.zip
Fix build with libc++ 3.8.0.
PR: 209967 Submitted by: me Approved by: Henry Hu <henry.hu.sh at gmail.com> (maintainer)
Diffstat (limited to 'net-im/telegramqml')
-rw-r--r--net-im/telegramqml/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-im/telegramqml/Makefile b/net-im/telegramqml/Makefile
index 96d2faf6f06e..1adcd39b9fc7 100644
--- a/net-im/telegramqml/Makefile
+++ b/net-im/telegramqml/Makefile
@@ -20,7 +20,13 @@ GH_PROJECT= TelegramQML
USES= qmake:outsource
USE_QT5= qmake_build buildtools_build core qml quick sql xml multimedia
+USE_OPENSSL= yes
USE_LDCONFIG= yes
-QMAKE_ARGS= BUILD_MODE+=lib
+QMAKE_ARGS= BUILD_MODE+=lib \
+ LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae"
+
+post-patch:
+ @${REINPLACE_CMD} -e "/isEmpty(OPENSSL_INCLUDE_PATH)/d" \
+ ${WRKSRC}/telegramqml.pri
.include <bsd.port.mk>