aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/telegramqml
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2016-09-05 00:42:33 +0800
committerrakuco <rakuco@FreeBSD.org>2016-09-05 00:42:33 +0800
commitfe5719cd3b45d87e315cb6c7f9f456b8a9c43565 (patch)
tree0580ac98734cd88fea36b672c17a973a1062e4c7 /net-im/telegramqml
parent9ead65e6f510cfab89fdabfc1015ca0c233b6c56 (diff)
downloadfreebsd-ports-gnome-fe5719cd3b45d87e315cb6c7f9f456b8a9c43565.tar.gz
freebsd-ports-gnome-fe5719cd3b45d87e315cb6c7f9f456b8a9c43565.tar.zst
freebsd-ports-gnome-fe5719cd3b45d87e315cb6c7f9f456b8a9c43565.zip
Explicitly disable C++11 during the build.
Prepare for Qt 5.6, which will pass -std=gnu++11 by default when the compiler supports it, and the build currently does not work: ../TelegramQML-0.9.2/telegramqml.cpp:4794:10: error: case value evaluates to 2573335900, which cannot be narrowed to type 'int' [-Wc++11-narrowing] case Update::typeUpdateReadHistoryInbox: Note that Qt 5.7 will start requiring C++11 support, so this will need to be fixed properly in the future. PR: 211916
Diffstat (limited to 'net-im/telegramqml')
-rw-r--r--net-im/telegramqml/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/net-im/telegramqml/Makefile b/net-im/telegramqml/Makefile
index 1adcd39b9fc7..b12866f19b86 100644
--- a/net-im/telegramqml/Makefile
+++ b/net-im/telegramqml/Makefile
@@ -25,6 +25,12 @@ USE_LDCONFIG= yes
QMAKE_ARGS= BUILD_MODE+=lib \
LIBQTELEGRAM_INCLUDE_PATH="${LOCALBASE}/include/libqtelegram-ae"
+# Explicitly disable C++11, as Qt 5.6 defaults to -std=gnu++11 when the
+# compiler supports it and the build currently fails.
+# ../TelegramQML-0.9.2/telegramqml.cpp:4794:10: error: case value evaluates to 2573335900, which cannot be narrowed to type 'int' [-Wc++11-narrowing]
+# case Update::typeUpdateReadHistoryInbox:
+QMAKE_ARGS+= CONFIG-="c++11"
+
post-patch:
@${REINPLACE_CMD} -e "/isEmpty(OPENSSL_INCLUDE_PATH)/d" \
${WRKSRC}/telegramqml.pri