aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/telepathy-logger-qt4/Makefile
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /net-im/telepathy-logger-qt4/Makefile
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'net-im/telepathy-logger-qt4/Makefile')
-rw-r--r--net-im/telepathy-logger-qt4/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/net-im/telepathy-logger-qt4/Makefile b/net-im/telepathy-logger-qt4/Makefile
index 081419dc4494..5495d805778c 100644
--- a/net-im/telepathy-logger-qt4/Makefile
+++ b/net-im/telepathy-logger-qt4/Makefile
@@ -17,11 +17,11 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libtelepathy-logger.so:net-im/telepathy-logger \
libtelepathy-qt4.so:net-im/telepathy-qt4
-USES= bison:build cmake kde:4 pkgconfig python:2.7,build tar:bzip2
+USES= bison:build cmake kde:4 pkgconfig python:2.7,build qt:4 tar:bzip2
USE_GNOME= glib20 libxml2
USE_GSTREAMER= qt4
USE_KDE= # empty
-USE_QT4= corelib dbus moc_build qmake_build rcc_build uic_build
+USE_QT= corelib dbus moc_build qmake_build rcc_build uic_build
CMAKE_ARGS= -DUSE_COMMON_CMAKE_PACKAGE_CONFIG_DIR:BOOL=True
USE_LDCONFIG= yes