aboutsummaryrefslogtreecommitdiffstats
path: root/net-im/zephyr
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
committertijl <tijl@FreeBSD.org>2014-08-26 22:06:08 +0800
commitf8357b5cbaa160ccdf9943cac099f5e092c591da (patch)
treed0c8617b772b8f0a175d436d938b8d844590b41f /net-im/zephyr
parent89a7d6ecbdde724b92ca6650493f56cf68855f35 (diff)
downloadfreebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.gz
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.tar.zst
freebsd-ports-gnome-f8357b5cbaa160ccdf9943cac099f5e092c591da.zip
- Fix missing library problems when the linker enforces explicit linking
PR: 192062 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'net-im/zephyr')
-rw-r--r--net-im/zephyr/files/patch-zhm__Makefile.in18
1 files changed, 18 insertions, 0 deletions
diff --git a/net-im/zephyr/files/patch-zhm__Makefile.in b/net-im/zephyr/files/patch-zhm__Makefile.in
new file mode 100644
index 000000000000..45bc1f432d63
--- /dev/null
+++ b/net-im/zephyr/files/patch-zhm__Makefile.in
@@ -0,0 +1,18 @@
+--- zhm/Makefile.in.orig 2014-08-21 09:11:35 UTC
++++ zhm/Makefile.in
+@@ -27,13 +27,14 @@ CFLAGS=@CFLAGS@
+ ALL_CFLAGS=${CFLAGS} -I${top_srcdir}/h -I${BUILDTOP}/h ${CPPFLAGS}
+ LDFLAGS=@LDFLAGS@
+ HESIOD_LIBS=@HESIOD_LIBS@
++LIBS=${LIBZEPHYR} -lcom_err ${HESIOD_LIBS} @LIBS@
+
+ OBJS= timer.o queue.o zhm.o zhm_client.o zhm_server.o
+
+ all: zhm
+
+ zhm: ${OBJS} ${LIBZEPHYR}
+- ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} -o $@ ${OBJS} ${LIBZEPHYR} ${HESIOD_LIBS}
++ ${LIBTOOL} --mode=link ${CC} ${LDFLAGS} -o $@ ${OBJS} ${LIBS}
+
+ .c.o:
+ ${CC} -c ${ALL_CFLAGS} $<