aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
committerwxs <wxs@FreeBSD.org>2009-07-16 00:47:45 +0800
commit5df5244832441b2891d52b6e4692f7826550fbf9 (patch)
treee5cc110a0c6b72dd9bb7f133efd52b77ab031c63 /net-im
parent194d70d50158859e626cd148123bb52dec698a06 (diff)
downloadfreebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.gz
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.tar.zst
freebsd-ports-gnome-5df5244832441b2891d52b6e4692f7826550fbf9.zip
- Chase security/gpgme update.
Most changes are just PORTREVISION and LIB_DEPENDS fixes. However, the following ports require a patch to use the new gpgme correctly: deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim3 deskutils/kdepim4 deskutils/kdepim4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 deskutils/kdepimlibs4 finance/qhacc mail/mutt-devel net-im/ayttm net-im/centericq net-im/centerim net-im/centerim-devel security/openvas-libnasl These patches were submitted by various people and documented in ports/135911. PR: ports/135911
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ayttm/Makefile3
-rw-r--r--net-im/ayttm/files/patch-modules__aycryption__aycryption.c11
-rw-r--r--net-im/centericq/Makefile4
-rw-r--r--net-im/centericq/files/patch-src_impgp.cc10
-rw-r--r--net-im/centerim-devel/Makefile3
-rw-r--r--net-im/centerim-devel/files/patch-src__impgp.cc10
-rw-r--r--net-im/centerim/Makefile3
-rw-r--r--net-im/centerim/files/patch-src__impgp.cc10
-rw-r--r--net-im/mcabber/Makefile3
9 files changed, 51 insertions, 6 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index a7e98fb5d283..5b4e2ec794fc 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ayttm
PORTVERSION= 0.5.0.82
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -16,7 +17,7 @@ COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
jasper.4:${PORTSDIR}/graphics/jasper \
- gpgme.17:${PORTSDIR}/security/gpgme \
+ gpgme.18:${PORTSDIR}/security/gpgme \
pspell.16:${PORTSDIR}/textproc/aspell
OPTIONS= ARTS "Enable aRts support" off \
diff --git a/net-im/ayttm/files/patch-modules__aycryption__aycryption.c b/net-im/ayttm/files/patch-modules__aycryption__aycryption.c
new file mode 100644
index 000000000000..9f0693f740ea
--- /dev/null
+++ b/net-im/ayttm/files/patch-modules__aycryption__aycryption.c
@@ -0,0 +1,11 @@
+--- ./modules/aycryption/aycryption.c.orig 2008-08-11 00:50:44.000000000 -0400
++++ ./modules/aycryption/aycryption.c 2009-07-02 04:06:35.000000000 -0400
+@@ -108,6 +108,8 @@
+
+ static int aycryption_init()
+ {
++ gpgme_check_version (NULL);
++
+ input_list *il = g_new0(input_list, 1);
+ plugin_info.prefs = il;
+
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index ae218f380148..8d94f9159806 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,7 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.21.0
-PORTREVISION= 10
+PORTREVISION= 11
CATEGORIES= net-im
MASTER_SITES= http://thekonst.net/download/
@@ -90,7 +90,7 @@ CONFIGURE_ARGS+= --disable-jabber
.if !defined(WITH_GPGME)
CONFIGURE_ARGS+= --without-gpgme
.else
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
.endif
.endif
diff --git a/net-im/centericq/files/patch-src_impgp.cc b/net-im/centericq/files/patch-src_impgp.cc
new file mode 100644
index 000000000000..cfa38bebf5f7
--- /dev/null
+++ b/net-im/centericq/files/patch-src_impgp.cc
@@ -0,0 +1,10 @@
+--- ./src/impgp.cc.orig 2009-07-01 23:19:00.000000000 -0400
++++ ./src/impgp.cc 2009-07-01 23:19:29.000000000 -0400
+@@ -12,6 +12,7 @@
+ string impgp::passphrase[];
+
+ impgp::impgp() {
++ gpgme_check_version(NULL);
+ if(gpgme_new(&ctx))
+ ctx = 0;
+ }
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index 47df155c3c1f..46b549f7130b 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -8,6 +8,7 @@
PORTNAME= centerim
DISTVERSION= 4.22.7-36-g6ba0
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.centerim.org/download/mobshots/ \
ftp://ftp.centerim.org/mobshots/
@@ -88,7 +89,7 @@ CONFIGURE_ARGS+= --disable-jabber
.if !defined(WITH_GPGME)
CONFIGURE_ARGS+= --without-gpgme
.else
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
#CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
CONFIGURE_ARGS+= --with-ssl
.endif
diff --git a/net-im/centerim-devel/files/patch-src__impgp.cc b/net-im/centerim-devel/files/patch-src__impgp.cc
new file mode 100644
index 000000000000..9cb74b224d92
--- /dev/null
+++ b/net-im/centerim-devel/files/patch-src__impgp.cc
@@ -0,0 +1,10 @@
+--- ./src/impgp.cc.orig 2009-07-01 23:27:35.000000000 -0400
++++ ./src/impgp.cc 2009-07-01 23:27:55.000000000 -0400
+@@ -13,6 +13,7 @@
+ string impgp::passphrase[];
+
+ impgp::impgp() {
++ gpgme_check_version(NULL);
+ if(gpgme_new(&ctx))
+ ctx = 0;
+ }
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index 080e936323ac..92f2dfb74816 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -8,6 +8,7 @@
PORTNAME= centerim
PORTVERSION= 4.22.7
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.centerim.org/download/releases/ \
ftp://ftp.centerim.org/releases/
@@ -88,7 +89,7 @@ CONFIGURE_ARGS+= --disable-jabber
.if !defined(WITH_GPGME)
CONFIGURE_ARGS+= --without-gpgme
.else
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
#CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
CONFIGURE_ARGS+= --with-ssl
.endif
diff --git a/net-im/centerim/files/patch-src__impgp.cc b/net-im/centerim/files/patch-src__impgp.cc
new file mode 100644
index 000000000000..2cd5b217ddb5
--- /dev/null
+++ b/net-im/centerim/files/patch-src__impgp.cc
@@ -0,0 +1,10 @@
+--- ./src/impgp.cc.orig 2009-07-01 23:25:08.000000000 -0400
++++ ./src/impgp.cc 2009-07-01 23:25:37.000000000 -0400
+@@ -13,6 +13,7 @@
+ string impgp::passphrase[];
+
+ impgp::impgp() {
++ gpgme_check_version(NULL);
+ if(gpgme_new(&ctx))
+ ctx = 0;
+ }
diff --git a/net-im/mcabber/Makefile b/net-im/mcabber/Makefile
index 23f96dc44b1d..9bdc3214e07b 100644
--- a/net-im/mcabber/Makefile
+++ b/net-im/mcabber/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mcabber
PORTVERSION= 0.9.9
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.lilotux.net/~mikael/mcabber/files/ CENKES
@@ -37,7 +38,7 @@ LIB_DEPENDS+= ncursesw.5:${PORTSDIR}/devel/ncurses
.endif
.if defined(WITH_GPGME)
-LIB_DEPENDS+= gpgme.17:${PORTSDIR}/security/gpgme
+LIB_DEPENDS+= gpgme.18:${PORTSDIR}/security/gpgme
CONFIGURE_ARGS+=--enable-gpgme
.else
CONFIGURE_ARGS+=--disable-gpgme