aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-01-11 00:31:33 +0800
committerbapt <bapt@FreeBSD.org>2016-01-11 00:31:33 +0800
commit834e21da3d78bade53f6940b62c4b1d11ff57062 (patch)
tree45355dccba19623f8780fff011f8b7e1a576c0e2 /net-im
parent0b449150804dd839d3aec0f8dcde508b07c60a84 (diff)
downloadfreebsd-ports-gnome-834e21da3d78bade53f6940b62c4b1d11ff57062.tar.gz
freebsd-ports-gnome-834e21da3d78bade53f6940b62c4b1d11ff57062.tar.zst
freebsd-ports-gnome-834e21da3d78bade53f6940b62c4b1d11ff57062.zip
Convert ports from s* t* and net* categories to USES=sqlite and USES=firebird
Diffstat (limited to 'net-im')
-rw-r--r--net-im/corebird/Makefile3
-rw-r--r--net-im/kopete-kde4/Makefile3
-rw-r--r--net-im/telepathy-gabble/Makefile3
-rw-r--r--net-im/telepathy-logger/Makefile3
-rw-r--r--net-im/telepathy-salut/Makefile3
5 files changed, 5 insertions, 10 deletions
diff --git a/net-im/corebird/Makefile b/net-im/corebird/Makefile
index c6cc85acfaf7..685eca3eb3bc 100644
--- a/net-im/corebird/Makefile
+++ b/net-im/corebird/Makefile
@@ -20,10 +20,9 @@ LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
USE_GITHUB= yes
GH_ACCOUNT= baedert
-USES= autoreconf gettext gmake libtool pkgconfig
+USES= autoreconf gettext gmake libtool pkgconfig sqlite
GNU_CONFIGURE= yes
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 intltool libxml2 pango
-USE_SQLITE= yes
INSTALLS_ICONS= yes
OPTIONS_DEFINE= GSTREAMER
diff --git a/net-im/kopete-kde4/Makefile b/net-im/kopete-kde4/Makefile
index 03305300ec0e..ca640b1b3247 100644
--- a/net-im/kopete-kde4/Makefile
+++ b/net-im/kopete-kde4/Makefile
@@ -20,13 +20,12 @@ LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
libjasper.so:${PORTSDIR}/graphics/jasper
BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
-USES= cmake:outsource jpeg pkgconfig shebangfix tar:xz webplugin:native
+USES= cmake:outsource jpeg pkgconfig shebangfix sqlite tar:xz webplugin:native
USE_GNOME= libxml2 libxslt
USE_KDE4= kdelibs kdeprefix pimlibs \
automoc4 qimageblitz
USE_QT4= corelib gui network qt3support sql xml \
moc_build qmake_build rcc_build uic_build uic3_build
-USE_SQLITE= yes
USE_XORG= x11 xdamage xext xscrnsaver xtst
USE_LDCONFIG= yes
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index aef4fc4c6b3a..1901dc6b0887 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -23,9 +23,8 @@ RUN_DEPENDS= ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss \
PORTSCOUT= limitw:1,even
-USES= alias gmake libtool pathfix pkgconfig python:build
+USES= alias gmake libtool pathfix pkgconfig python:build sqlite
USE_GNOME= glib20 gtksourceview3 libxslt:build
-USE_SQLITE= 3
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
diff --git a/net-im/telepathy-logger/Makefile b/net-im/telepathy-logger/Makefile
index 22f3da7698a6..1fb07c28aad2 100644
--- a/net-im/telepathy-logger/Makefile
+++ b/net-im/telepathy-logger/Makefile
@@ -16,12 +16,11 @@ LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libtelepathy-glib.so:${PORTSDIR}/net-im/telepathy-glib
USES= gettext-tools gmake libtool pathfix pkgconfig python:build \
- tar:bzip2
+ sqlite tar:bzip2
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_GNOME= glib20 gnomedocutils intltool libxml2 \
libxslt:build introspection:build
-USE_SQLITE= yes
GLIB_SCHEMAS= org.freedesktop.Telepathy.Logger.gschema.xml
INSTALL_TARGET= install-strip
diff --git a/net-im/telepathy-salut/Makefile b/net-im/telepathy-salut/Makefile
index 07b29bad014a..3d3d7a1d5478 100644
--- a/net-im/telepathy-salut/Makefile
+++ b/net-im/telepathy-salut/Makefile
@@ -16,10 +16,9 @@ LIB_DEPENDS= libavahi-glib.so:${PORTSDIR}/net/avahi-app \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig python:build
+USES= gmake libtool pathfix pkgconfig python:build sqlite
USE_GNOME= glib20 libxslt:build
USE_OPENSSL= yes
-USE_SQLITE= 3
CONFIGURE_ARGS= --disable-Werror --enable-avahi-tests=no
LDFLAGS+= -lpthread
INSTALL_TARGET= install-strip