aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2017-02-18 16:00:14 +0800
committerdinoex <dinoex@FreeBSD.org>2017-02-18 16:00:14 +0800
commit6dcd0498ddd03cc8943ed8a97a2f7197f2b8d5f8 (patch)
tree5de3e9aa1630e72dd74ca3ad2583f00aa17b37a3 /net-im
parent1ed1dfd3a28a440d65a0329108206958b4ffa4c4 (diff)
downloadfreebsd-ports-gnome-6dcd0498ddd03cc8943ed8a97a2f7197f2b8d5f8.tar.gz
freebsd-ports-gnome-6dcd0498ddd03cc8943ed8a97a2f7197f2b8d5f8.tar.zst
freebsd-ports-gnome-6dcd0498ddd03cc8943ed8a97a2f7197f2b8d5f8.zip
- make portlint happier
- add dependecies
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq-icq/files/patch-filetransfer.h4
-rw-r--r--net-im/licq-osd/Makefile7
-rw-r--r--net-im/licq-qt-gui/Makefile4
-rw-r--r--net-im/licq-qt-gui/files/patch-contactuserdata.h4
-rw-r--r--net-im/licq-qt-gui/files/patch-plugin.cpp4
-rw-r--r--net-im/licq-qt-gui/files/patch-usereventcommon.h4
-rw-r--r--net-im/licq/Makefile3
-rw-r--r--net-im/licq/files/patch-filetransfer.h4
-rw-r--r--net-im/licq/files/patch-main.cpp6
9 files changed, 18 insertions, 22 deletions
diff --git a/net-im/licq-icq/files/patch-filetransfer.h b/net-im/licq-icq/files/patch-filetransfer.h
index 1014a3cd9e44..5b640b9d4274 100644
--- a/net-im/licq-icq/files/patch-filetransfer.h
+++ b/net-im/licq-icq/files/patch-filetransfer.h
@@ -1,5 +1,5 @@
---- ../../include/licq/icq/filetransfer.h.orig 2013-08-25 11:45:17.000000000 +0200
-+++ ../../include/licq/icq/filetransfer.h 2014-02-13 21:38:18.000000000 +0100
+--- ../../include/licq/icq/filetransfer.h.orig 2014-06-01 19:16:42 UTC
++++ ../../include/licq/icq/filetransfer.h
@@ -76,6 +76,7 @@
#include <cstring>
#include <list>
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index 370860ab06f7..3d1d38799ec0 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= osd
PORTVERSION= 1.8.2
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 2
CATEGORIES= net-im
@@ -13,11 +13,8 @@ COMMENT= OnScreenDisplay messages in licq
LIB_DEPENDS= libxosd.so:misc/xosd \
libboost_regex.so:devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/lib/licq/licq_qt4-gui.so:${LICQ_PORT}-qt-gui
-# run dependency may be too strict, delete it if you use another
-# plugin (gtk+) and wish run osd with it. i've not tested with
-# plugins other than qt-gui
-USES= cmake gettext-tools
+USES= cmake gettext-tools iconv
LOCALES= be de cs es fr pt pt_BR ro ru sv sk tr
PLIST_FILES= lib/licq/licq_osd.so \
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index d6bde30efcc9..0a27ee0a20a2 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -15,10 +15,10 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_regex.so:devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/lib/licq/protocol_icq.so:${LICQ_PORT}-icq
-USE_XORG= x11 xext ice xscrnsaver
+USE_XORG= x11 xext ice xscrnsaver sm
USES= cmake
USE_QT4= qmake_build moc_build rcc_build uic_build linguisttools_build \
- corelib xml gui
+ corelib xml gui network dbus svg
OPTIONS_DEFINE= HUNSPELL KDE4
OPTIONS_DEFAULT=HUNSPELL
diff --git a/net-im/licq-qt-gui/files/patch-contactuserdata.h b/net-im/licq-qt-gui/files/patch-contactuserdata.h
index 9cf5faba7616..fd4c2238309a 100644
--- a/net-im/licq-qt-gui/files/patch-contactuserdata.h
+++ b/net-im/licq-qt-gui/files/patch-contactuserdata.h
@@ -1,5 +1,5 @@
---- src/contactlist/contactuserdata.h.orig 2013-08-25 11:45:17.000000000 +0200
-+++ src/contactlist/contactuserdata.h 2014-02-13 21:44:51.000000000 +0100
+--- src/contactlist/contactuserdata.h.orig 2014-06-01 19:16:42 UTC
++++ src/contactlist/contactuserdata.h
@@ -20,6 +20,8 @@
#ifndef CONTACTUSERDATA_H
#define CONTACTUSERDATA_H
diff --git a/net-im/licq-qt-gui/files/patch-plugin.cpp b/net-im/licq-qt-gui/files/patch-plugin.cpp
index df1a020d83f3..60396e4990fd 100644
--- a/net-im/licq-qt-gui/files/patch-plugin.cpp
+++ b/net-im/licq-qt-gui/files/patch-plugin.cpp
@@ -1,5 +1,5 @@
---- src/core/plugin.cpp.orig 2014-06-01 21:16:42.000000000 +0200
-+++ src/core/plugin.cpp 2014-06-06 22:08:35.000000000 +0200
+--- src/core/plugin.cpp.orig 2014-06-01 19:16:42 UTC
++++ src/core/plugin.cpp
@@ -31,6 +31,7 @@
# include <QInternal>
#include <KDE/KCmdLineArgs>
diff --git a/net-im/licq-qt-gui/files/patch-usereventcommon.h b/net-im/licq-qt-gui/files/patch-usereventcommon.h
index 469fa802084d..524a8d7ac972 100644
--- a/net-im/licq-qt-gui/files/patch-usereventcommon.h
+++ b/net-im/licq-qt-gui/files/patch-usereventcommon.h
@@ -1,5 +1,5 @@
---- src/userevents/usereventcommon.h.orig 2013-08-25 11:45:17.000000000 +0200
-+++ src/userevents/usereventcommon.h 2014-02-13 21:45:16.000000000 +0100
+--- src/userevents/usereventcommon.h.orig 2014-06-01 19:16:42 UTC
++++ src/userevents/usereventcommon.h
@@ -20,6 +20,8 @@
#ifndef USEREVENTCOMMON_H
#define USEREVENTCOMMON_H
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index aa24b2050c5d..68976f9b4996 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -17,8 +17,7 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs
BROKEN_powerpc64= Does not build
BROKEN_sparc64= Does not build: fails to link
-USES= cmake iconv
-USE_OPENSSL= yes
+USES= cmake iconv ssl
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
diff --git a/net-im/licq/files/patch-filetransfer.h b/net-im/licq/files/patch-filetransfer.h
index 0962558998d0..d4ff21cc1a58 100644
--- a/net-im/licq/files/patch-filetransfer.h
+++ b/net-im/licq/files/patch-filetransfer.h
@@ -1,5 +1,5 @@
---- include/licq/icq/filetransfer.h.orig 2014-06-01 21:16:42.000000000 +0200
-+++ include/licq/icq/filetransfer.h 2014-06-06 15:47:07.000000000 +0200
+--- include/licq/icq/filetransfer.h.orig 2014-06-01 19:16:42 UTC
++++ include/licq/icq/filetransfer.h
@@ -73,6 +73,7 @@
* which case the file will be saved as <filename>.<timestamp>
*-------------------------------------------------------------------------*/
diff --git a/net-im/licq/files/patch-main.cpp b/net-im/licq/files/patch-main.cpp
index e6ca09b4f421..23c673667cf0 100644
--- a/net-im/licq/files/patch-main.cpp
+++ b/net-im/licq/files/patch-main.cpp
@@ -1,6 +1,6 @@
---- src/main.cpp.orig Wed Jan 29 13:19:50 2003
-+++ src/main.cpp Wed Jan 29 13:20:13 2003
-@@ -10,7 +10,6 @@
+--- src/main.cpp.orig 2014-06-01 19:16:42 UTC
++++ src/main.cpp
+@@ -31,7 +31,6 @@
#ifdef USE_SOCKS5
#define SOCKS