aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2015-12-20 05:40:41 +0800
committermarcus <marcus@FreeBSD.org>2015-12-20 05:40:41 +0800
commitae9fb044d72a1f7022127bac9f2dc9c87db296d4 (patch)
tree4ec57fc59865b5f649e7d0a3c928ecd001c4b323 /net-im
parent1fbb30693dbecb4e8c43bf5e8d20e1a47925dd41 (diff)
downloadfreebsd-ports-gnome-ae9fb044d72a1f7022127bac9f2dc9c87db296d4.tar.gz
freebsd-ports-gnome-ae9fb044d72a1f7022127bac9f2dc9c87db296d4.tar.zst
freebsd-ports-gnome-ae9fb044d72a1f7022127bac9f2dc9c87db296d4.zip
Add support for building finch with port's ncurses.
PR: 205407
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libpurple/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 2def4cb4c144..c7dd47fb6be2 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -77,6 +77,8 @@ PLIST_SUB+= GTKUI="@comment not installed: "
.endif
.if defined(WITH_CONSOLEUI)
+OPTIONS_DEFINE+=NCURSES
+NCURSES_DESC= Build with ncurses from ports
PLIST_SUB+= CONSOLEUI=""
.else
PLIST_SUB+= CONSOLEUI="@comment not installed: "
@@ -97,6 +99,13 @@ CONFIGURE_ARGS+= --disable-tcl
PLIST_SUB+= TCL:="@comment not installed: "
.endif
+.if ${PORT_OPTIONS:MNCURSES}
+USES+= ncurses:port
+CONFIGURE_ARGS+=--with-ncurses-headers=${LOCALBASE}/include/ncurses/
+.else
+USES+= ncurses
+.endif
+
.include <bsd.port.pre.mk>
.if !defined(PIDGIN_SLAVE)