aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-09-10 23:32:24 +0800
committertobik <tobik@FreeBSD.org>2018-09-10 23:32:24 +0800
commit22629f57f6a481cbfb55e35ada3337396b54c5c3 (patch)
treec9a357cdf141e9014becee58d4854d1deb0ebbf1 /net-im
parenta575ab6ceeb6d60d09398a9d3eab2d656a4f3dab (diff)
downloadfreebsd-ports-gnome-22629f57f6a481cbfb55e35ada3337396b54c5c3.tar.gz
freebsd-ports-gnome-22629f57f6a481cbfb55e35ada3337396b54c5c3.tar.zst
freebsd-ports-gnome-22629f57f6a481cbfb55e35ada3337396b54c5c3.zip
net-im/centerim{,-devel}: Fix build with Clang 6
In file included from rsshook.cc:32: ../../src/icqface.h:248:50: error: cannot combine with previous 'bool' declaration specifier bool findresults(const imsearchparams &sp, bool auto = false); ^ ... and more if one gets past this http://beefy12.nyi.freebsd.org/data/head-amd64-default/p479076_s338486/logs/errors/centerim-4.22.10_5.log http://beefy12.nyi.freebsd.org/data/head-amd64-default/p479076_s338486/logs/errors/centerim-devel-4.22.10.11_7.log PR: 230904 Approved by: frank@altpeter.de (maintainer timeout, 2 weeks)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centerim-devel/Makefile1
-rw-r--r--net-im/centerim/Makefile1
2 files changed, 2 insertions, 0 deletions
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index 38402c1b504e..058b7bfbda6a 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -18,6 +18,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcurl.so:ftp/curl
USES= iconv gmake ncurses perl5 pkgconfig python:2.7,run shebangfix ssl
+USE_CXXSTD= gnu++98
USE_PERL5= run
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --with-openssl
diff --git a/net-im/centerim/Makefile b/net-im/centerim/Makefile
index d372b0b3138d..9d5e00b06fd2 100644
--- a/net-im/centerim/Makefile
+++ b/net-im/centerim/Makefile
@@ -19,6 +19,7 @@ LIB_DEPENDS= libassuan.so:security/libassuan \
libgpg-error.so:security/libgpg-error
USES= iconv gmake ncurses pkgconfig python shebangfix ssl
+USE_CXXSTD= gnu++98
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -I${LOCALBASE}/include