aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-12-01 19:18:03 +0800
committermat <mat@FreeBSD.org>2016-12-01 19:18:03 +0800
commit359f486d9eb2765e2538b660686a47ca7f489039 (patch)
tree33a19b5745c1e5e7cbfa4a5ab2c30f6971177e74 /net-im
parent16d9767b56dfb66fc3cda0c10604d546bd95003f (diff)
downloadfreebsd-ports-gnome-359f486d9eb2765e2538b660686a47ca7f489039.tar.gz
freebsd-ports-gnome-359f486d9eb2765e2538b660686a47ca7f489039.tar.zst
freebsd-ports-gnome-359f486d9eb2765e2538b660686a47ca7f489039.zip
Don't quote {} in find -exec calls.
Braces are not shell metacharacters, and they do not need to be quoted. By the time find parses its arguments and dicovers them, the quoting will have been removed by the shell anyway. Sponsored by: Absolight
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ejabberd/Makefile2
-rw-r--r--net-im/jabber-pyicq/Makefile4
2 files changed, 3 insertions, 3 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 3ba59cdb0251..8869ab9e5ca8 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -101,6 +101,6 @@ post-install:
${STAGEDIR}${PREFIX}/${EJABBERD_LIBDIR}/${PORTNAME}-${PORTVERSION}/priv/bin/epam
.endif
@${FIND} ${STAGEDIR}${PREFIX}/${EJABBERD_LIBDIR} -type f \
- -name '*.so' -exec ${STRIP_CMD} '{}' \;
+ -name '*.so' -exec ${STRIP_CMD} {} \;
.include <bsd.port.post.mk>
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index 1e6cd012c2ef..8ec8ad2808ac 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -96,8 +96,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/data/defaultAIMAvatar.png ${STAGEDIR}${INST_DIR}/data/
${INSTALL_DATA} ${WRKSRC}/data/defaultICQAvatar.png ${STAGEDIR}${INST_DIR}/data/
${CP} -Rv ${WRKSRC}/src/* ${STAGEDIR}${INST_DIR}/src/
- ${FIND} ${STAGEDIR}${INST_DIR}/src/ -type d -exec ${CHMOD} 755 "{}" \;
- ${FIND} ${STAGEDIR}${INST_DIR}/src/ -type f -exec ${CHMOD} 644 "{}" \;
+ ${FIND} ${STAGEDIR}${INST_DIR}/src/ -type d -exec ${CHMOD} 755 {} \;
+ ${FIND} ${STAGEDIR}${INST_DIR}/src/ -type f -exec ${CHMOD} 644 {} \;
${INSTALL_DATA} ${WRKSRC}/config_example.xml ${STAGEDIR}${PREFIX}/etc/jabber-pyicq.xml.sample
${MKDIR} ${STAGEDIR}${DOCSDIR}/
cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/