aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2018-06-22 01:53:48 +0800
committertobik <tobik@FreeBSD.org>2018-06-22 01:53:48 +0800
commit42cfec816a696e1ea6a01f61cccef3997ccc0890 (patch)
tree44a32e9e208fb666ef4220eb68f6efeb28754413 /net-im
parente6525d566a8cbfe2fb59ed00329f67f414418726 (diff)
downloadfreebsd-ports-gnome-42cfec816a696e1ea6a01f61cccef3997ccc0890.tar.gz
freebsd-ports-gnome-42cfec816a696e1ea6a01f61cccef3997ccc0890.tar.zst
freebsd-ports-gnome-42cfec816a696e1ea6a01f61cccef3997ccc0890.zip
net-im/uTox: Update to 0.17.0
- Update license and WWW Changes: https://github.com/uTox/uTox/releases PR: 229198 Submitted by: tobik Approved by: maintainer
Diffstat (limited to 'net-im')
-rw-r--r--net-im/uTox/Makefile40
-rw-r--r--net-im/uTox/distinfo6
-rw-r--r--net-im/uTox/files/patch-CMakeLists.txt22
-rw-r--r--net-im/uTox/files/patch-src_main.h13
-rw-r--r--net-im/uTox/files/patch-src_xlib_main.c28
-rw-r--r--net-im/uTox/files/patch-src_xlib_video.c12
-rw-r--r--net-im/uTox/pkg-descr2
-rw-r--r--net-im/uTox/pkg-plist17
8 files changed, 56 insertions, 84 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index cfd6040603fd..b518c8f8197b 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -1,48 +1,38 @@
# $FreeBSD$
PORTNAME= uTox
-PORTVERSION= 0.11.1
-PORTREVISION= 6
+DISTVERSION= 0.17.0
+DISTVERSIONSUFFIX= -full
CATEGORIES= net-im net-p2p
+MASTER_SITES= https://github.com/uTox/uTox/releases/download/v${PORTVERSION}/
MAINTAINER= portmaster@BSDforge.com
COMMENT= Lightweight Tox client
-LICENSE= GPLv3
+LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox12 \
- ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
+BUILD_DEPENDS= ${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig \
libsodium.so:security/libsodium \
libv4lconvert.so:multimedia/libv4l \
libvpx.so:multimedia/libvpx \
- libfilteraudio.so:audio/libfilteraudio\
- libopus.so:audio/opus
-RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:net-im/tox12
-
-USE_GITHUB= yes
-GH_TAGNAME= 1835eae
-
-USES= cmake compiler:c11 desktop-file-utils localbase:ldflags openal:al \
- pkgconfig
-USE_XORG= x11 xext xrender
+ libopus.so:audio/opus \
+ libtoxcore.so:net-im/tox
+
+USES= cmake:outsource compiler:c11 desktop-file-utils dos2unix \
+ openal pkgconfig
+USE_XORG= ice sm x11 xext xrender
+CMAKE_OFF= ENABLE_LTO
+DOS2UNIX_GLOB= *
LLD_UNSAFE= yes
+WRKSRC= ${WRKDIR}/uTox
OPTIONS_DEFINE= DBUS
OPTIONS_DEFAULT= DBUS
+DBUS_CMAKE_BOOL= ENABLE_DBUS
DBUS_LIB_DEPENDS= libdbus-1.so:devel/dbus
-DBUS_MAKE_ARGS_OFF= DBUS=0
-
-pre-configure:
- ${REINPLACE_CMD} -e 's|resolv dl||' \
- -e 's|/usr/include/freetype2|${LOCALBASE}/include/freetype2|' \
- ${WRKSRC}/CMakeLists.txt
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/utox
- ${INSTALL_DATA} ${WRKSRC}/icons/utox-128x128.png ${STAGEDIR}${PREFIX}/share/pixmaps/utox.png
.include <bsd.port.mk>
diff --git a/net-im/uTox/distinfo b/net-im/uTox/distinfo
index 2e9baac14751..7b3cd9f8c335 100644
--- a/net-im/uTox/distinfo
+++ b/net-im/uTox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1483474222
-SHA256 (uTox-uTox-0.11.1-1835eae_GH0.tar.gz) = bd6c093c30ee56315dc97dc70bc32a761b748c761353eadb6e940a5cdbc5891d
-SIZE (uTox-uTox-0.11.1-1835eae_GH0.tar.gz) = 2378596
+TIMESTAMP = 1529567839
+SHA256 (uTox-0.17.0-full.tar.gz) = 219ae83e9139d3a421c7bb6d03cc3f8953dd36fb8e8b67100d47d92d413e9d46
+SIZE (uTox-0.17.0-full.tar.gz) = 3946812
diff --git a/net-im/uTox/files/patch-CMakeLists.txt b/net-im/uTox/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..9ffa23fc7e38
--- /dev/null
+++ b/net-im/uTox/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2018-06-21 08:33:29 UTC
++++ CMakeLists.txt
+@@ -184,8 +184,7 @@ add_cflag("-fPIC")
+ # Fix GNU stack
+ if(CMAKE_C_COMPILER_ID MATCHES "GNU")
+ # Have ld strip the symbols from Release and MinSizeRel build types.
+- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -Os")
+- set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -Os -s")
++ set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -s")
+
+ if(LINUX)
+ # enable Link Time Optimization on gcc (linux only currently)
+@@ -220,8 +219,7 @@ elseif(CMAKE_C_COMPILER_ID MATCHES "Clang")
+ endif()
+
+ # Have ld strip the symbols from Release and MinSizeRel build types. (-Oz is clang specific)
+- set(CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE} -Os")
+- set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -Oz -s")
++ set(CMAKE_C_FLAGS_MINSIZEREL "${CMAKE_C_FLAGS_MINSIZEREL} -s")
+
+ if(NOT ENABLE_ASAN)
+ if(NOT APPLE)
diff --git a/net-im/uTox/files/patch-src_main.h b/net-im/uTox/files/patch-src_main.h
deleted file mode 100644
index 85ba916bbb35..000000000000
--- a/net-im/uTox/files/patch-src_main.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/main.h.orig 2016-12-21 09:12:44 UTC
-+++ src/main.h
-@@ -80,8 +80,8 @@
- #define volatile(x) (*((volatile typeof(x)*)&x))
- #endif */
-
--#ifndef __OBJC__
--#define volatile(x)(x)
-+#if !defined(__OBJC__) || defined(__NetBSD__) || defined(__FreeBSD__)
-+#define volatile(x)(x)
- #endif
-
- #define SCALE(x) (((int)((ui_scale / 10.0) * ((double)x))) ?: 1)
diff --git a/net-im/uTox/files/patch-src_xlib_main.c b/net-im/uTox/files/patch-src_xlib_main.c
deleted file mode 100644
index 14c2991bef2f..000000000000
--- a/net-im/uTox/files/patch-src_xlib_main.c
+++ /dev/null
@@ -1,28 +0,0 @@
---- src/xlib/main.c.orig 2016-12-21 09:12:44 UTC
-+++ src/xlib/main.c
-@@ -35,7 +35,9 @@ void postmessage(uint32_t msg, uint16_t
- XFlush(display);
- }
-
-+#ifdef __LINUX__
- #include <linux/input.h>
-+#endif
- FILE * ptt_keyboard_handle;
- Display *ptt_display;
- void init_ptt(void) {
-@@ -60,6 +62,7 @@ bool check_ptt_key(void) {
- int ptt_key;
-
- /* First, we try for direct access to the keyboard. */
-+#ifdef __LINUX__
- ptt_key = KEY_LEFTCTRL; // TODO allow user to change this...
- if (ptt_keyboard_handle) {
- /* Nice! we have direct access to the keyboard! */
-@@ -78,6 +81,7 @@ bool check_ptt_key(void) {
- return 0;
- }
- }
-+#endif
- /* Okay nope, lets' fallback to xinput... *pouts*
- * Fall back to Querying the X for the current keymap. */
- ptt_key = XKeysymToKeycode(display, XK_Control_L);
diff --git a/net-im/uTox/files/patch-src_xlib_video.c b/net-im/uTox/files/patch-src_xlib_video.c
deleted file mode 100644
index 5a943493afd0..000000000000
--- a/net-im/uTox/files/patch-src_xlib_video.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xlib/video.c.orig 2016-12-21 09:12:44 UTC
-+++ src/xlib/video.c
-@@ -144,6 +144,9 @@ bool native_video_init(void *handle) {
- if (isdesktop(handle)) {
- utox_v4l_fd = -1;
-
-+#ifndef volatile
-+#define volatile(x) (*((volatile typeof(x)*)&x))
-+#endif
- video_x = volatile(grabx);
- video_y = volatile(graby);
- video_width = volatile(grabpx);
diff --git a/net-im/uTox/pkg-descr b/net-im/uTox/pkg-descr
index b4215e6ad4d8..cf4dc763fd1f 100644
--- a/net-im/uTox/pkg-descr
+++ b/net-im/uTox/pkg-descr
@@ -9,4 +9,4 @@ important features, like file transfers, A/V, group chats, and DNS Discovery.
There are also binaries for other OS: Linux, Android, OS X and Windows, which
makes it possible to communicate between users of different OS.
-WWW: http://utox.org/
+WWW: https://utox.io/
diff --git a/net-im/uTox/pkg-plist b/net-im/uTox/pkg-plist
index 1510ed4baff9..bc744831c0a3 100644
--- a/net-im/uTox/pkg-plist
+++ b/net-im/uTox/pkg-plist
@@ -1,4 +1,17 @@
bin/utox
-share/applications/utox.desktop
-share/pixmaps/utox.png
man/man1/utox.1.gz
+share/applications/utox.desktop
+share/icons/hicolor/128x128/apps/utox-128x128.png
+share/icons/hicolor/14x14/apps/utox-14x14.png
+share/icons/hicolor/16x16/apps/utox-16x16.png
+share/icons/hicolor/22x22/apps/utox-22x22.png
+share/icons/hicolor/24x24/apps/utox-24x24.png
+share/icons/hicolor/256x256/apps/utox-256x256.png
+share/icons/hicolor/32x32/apps/utox-32x32.png
+share/icons/hicolor/36x36/apps/utox-36x36.png
+share/icons/hicolor/48x48/apps/utox-48x48.png
+share/icons/hicolor/512x512/apps/utox-512x512.png
+share/icons/hicolor/64x64/apps/utox-64x64.png
+share/icons/hicolor/72x72/apps/utox-72x72.png
+share/icons/hicolor/96x96/apps/utox-96x96.png
+share/icons/hicolor/scalable/apps/utox.svg