aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
committerade <ade@FreeBSD.org>2004-03-14 14:17:56 +0800
commit9291e9a32f6612ca0d4f25bdcb5c417e0451d313 (patch)
tree545e55afde412d844a25f5c03d6d51b17ceeebb9 /net-im
parenta8a89c37fe338cbff0192ceeef27ccf7a13714a5 (diff)
downloadfreebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.gz
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.tar.zst
freebsd-ports-gnome-9291e9a32f6612ca0d4f25bdcb5c417e0451d313.zip
Whoa there, boy, that's a mighty big commit y'all have there...
Begin autotools sanitization sequence by requiring ports to explicitly specify which version of {libtool,autoconf,automake} they need, erasing the concept of a "system default". For ports-in-waiting: USE_LIBTOOL=YES -> USE_LIBTOOL_VER=13 USE_AUTOCONF=YES -> USE_AUTOCONF_VER=213 USE_AUTOMAKE=YES -> USE_AUTOMAKE_VER=14 Ports attempting to use the old style system after June 1st 2004 will be sorely disappointed.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ayttm/Makefile2
-rw-r--r--net-im/fugu/Makefile2
-rw-r--r--net-im/gale/Makefile2
-rw-r--r--net-im/gnomeicu/Makefile2
-rw-r--r--net-im/gnomeicu2/Makefile2
-rw-r--r--net-im/icqlib/Makefile2
-rw-r--r--net-im/jabber-aim/Makefile2
-rw-r--r--net-im/libicq/Makefile2
-rw-r--r--net-im/libicq2000/Makefile2
-rw-r--r--net-im/licq-osd/Makefile2
-rw-r--r--net-im/loudmouth/Makefile2
11 files changed, 11 insertions, 11 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index b6b632fa973a..b824feef2d9c 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -30,7 +30,7 @@ USE_OPENSSL= yes
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
LIBTOOLFLAGS= # none
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-smtp --enable-jasper-filter
diff --git a/net-im/fugu/Makefile b/net-im/fugu/Makefile
index 148b870c3396..33c03819949d 100644
--- a/net-im/fugu/Makefile
+++ b/net-im/fugu/Makefile
@@ -19,7 +19,7 @@ USE_OPENSSL= yes
USE_PYTHON= yes
USE_XLIB= yes
USE_X_PREFIX= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index 1133926979d7..d451472481d7 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww \
USE_OPENSSL= yes
USE_AUTOCONF_VER=213
USE_AUTOMAKE_VER=14
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
diff --git a/net-im/gnomeicu/Makefile b/net-im/gnomeicu/Makefile
index d803657f3923..87421701e138 100644
--- a/net-im/gnomeicu/Makefile
+++ b/net-im/gnomeicu/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libglade2 gnomepanel libxml2
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
.if defined(WITH_DANTE)
LIB_DEPENDS+= socks.1:${PORTSDIR}/net/dante
diff --git a/net-im/gnomeicu2/Makefile b/net-im/gnomeicu2/Makefile
index d803657f3923..87421701e138 100644
--- a/net-im/gnomeicu2/Makefile
+++ b/net-im/gnomeicu2/Makefile
@@ -23,7 +23,7 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libglade2 gnomepanel libxml2
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
.if defined(WITH_DANTE)
LIB_DEPENDS+= socks.1:${PORTSDIR}/net/dante
diff --git a/net-im/icqlib/Makefile b/net-im/icqlib/Makefile
index 9fd959b96fe4..b2dd8d12793f 100644
--- a/net-im/icqlib/Makefile
+++ b/net-im/icqlib/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= lioux@FreeBSD.org
COMMENT= A library required by kicq (not libicq)
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_GMAKE= yes
USE_SIZE= yes
diff --git a/net-im/jabber-aim/Makefile b/net-im/jabber-aim/Makefile
index 800b501799fa..911f0a3db740 100644
--- a/net-im/jabber-aim/Makefile
+++ b/net-im/jabber-aim/Makefile
@@ -19,7 +19,7 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/jabberd:${PORTSDIR}/net/jabber
PLIST_FILES= lib/jabber/aimtrans.so
USE_GMAKE= yes
-USE_AUTOCONF= yes
+USE_AUTOCONF_VER= 213
CONFIGURE_ARGS+= --with-jabberd=${PREFIX}/include/jabber
diff --git a/net-im/libicq/Makefile b/net-im/libicq/Makefile
index 31ca46a1f2a9..2a3b12c43d0a 100644
--- a/net-im/libicq/Makefile
+++ b/net-im/libicq/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= flathill@FreeBSD.org
COMMENT= Library to add ICQ communication support to your software
USE_GNOME= glib12
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
.include <bsd.port.mk>
diff --git a/net-im/libicq2000/Makefile b/net-im/libicq2000/Makefile
index 341a70ef2e8b..a5485be12ec3 100644
--- a/net-im/libicq2000/Makefile
+++ b/net-im/libicq2000/Makefile
@@ -17,7 +17,7 @@ COMMENT= An opensource C++ library to support icq2000/2001 protocol
LIB_DEPENDS= sigc.1:${PORTSDIR}/devel/libsigc++
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
USE_REINPLACE= yes
USE_SIZE= yes
INSTALLS_SHLIB= yes
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index 4aab35df4c4e..70507b1d9289 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -26,6 +26,6 @@ RUN_DEPENDS=${LOCALBASE}/lib/licq/licq_qt-gui.so:${PORTSDIR}/net/licq-qt-gui
GNU_CONFIGURE=yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv"
-USE_LIBTOOL=yes
+USE_LIBTOOL_VER=13
.include <bsd.port.mk>
diff --git a/net-im/loudmouth/Makefile b/net-im/loudmouth/Makefile
index 4412e40dd521..bef23628c623 100644
--- a/net-im/loudmouth/Makefile
+++ b/net-im/loudmouth/Makefile
@@ -17,7 +17,7 @@ COMMENT= Lightweight Jabber client library
USE_BZIP2= yes
USE_GMAKE= yes
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
USE_GNOME= gnomehack glib20
CONFIGURE_ARGS= --disable-gtk-doc