aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-09-20 14:09:20 +0800
committerclsung <clsung@FreeBSD.org>2007-09-20 14:09:20 +0800
commitb771a55a0a74f4c102c9dead9fe7ba27db6eff32 (patch)
tree50767072b18a0e682cbebcfd0dcc67b8ee5f173d /net-im
parentc907b4759b294f689cf3e5ac0e740b88dee9e016 (diff)
downloadfreebsd-ports-gnome-b771a55a0a74f4c102c9dead9fe7ba27db6eff32.tar.gz
freebsd-ports-gnome-b771a55a0a74f4c102c9dead9fe7ba27db6eff32.tar.zst
freebsd-ports-gnome-b771a55a0a74f4c102c9dead9fe7ba27db6eff32.zip
Jabber::Lite is, as the name implies, a small 'lite' library for
dealing with Jabber servers, implemented entirely in perl. Whilst it is small, it does try to be fairly complete for common tasks. WWW: http://search.cpan.org/dist/Jabber-Lite/ PR: ports/116056 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/p5-Jabber-Lite/Makefile33
-rw-r--r--net-im/p5-Jabber-Lite/distinfo3
-rw-r--r--net-im/p5-Jabber-Lite/pkg-descr5
-rw-r--r--net-im/p5-Jabber-Lite/pkg-plist6
5 files changed, 48 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index a7d84e59c1b2..71a9a8383c75 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -100,6 +100,7 @@
SUBDIR += pymsn
SUBDIR += p5-DJabberd
SUBDIR += p5-Jabber-Connection
+ SUBDIR += p5-Jabber-Lite
SUBDIR += p5-Jabber-SimpleSend
SUBDIR += p5-Net-AIM
SUBDIR += p5-Net-AOLIM
diff --git a/net-im/p5-Jabber-Lite/Makefile b/net-im/p5-Jabber-Lite/Makefile
new file mode 100644
index 000000000000..b7dc53ea7b18
--- /dev/null
+++ b/net-im/p5-Jabber-Lite/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-Jabber-Lite
+# Date created: 2007-09-03
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Jabber-Lite
+PORTVERSION= 0.8
+CATEGORIES= net-im perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Jabber
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Standalone library for communicating with Jabber servers
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
+ ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
+ ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+
+PERL_CONFIGURE= yes
+
+MAN3= Jabber::Lite.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
+ ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/p5-Jabber-Lite/distinfo b/net-im/p5-Jabber-Lite/distinfo
new file mode 100644
index 000000000000..d0c0d3426ffb
--- /dev/null
+++ b/net-im/p5-Jabber-Lite/distinfo
@@ -0,0 +1,3 @@
+MD5 (Jabber-Lite-0.8.tar.gz) = 0e864c9e3e2de68390d805407ceb725f
+SHA256 (Jabber-Lite-0.8.tar.gz) = 095cdd6b40b3fdc04841b3d265c24fc32fac2e8da1e6618e1c74931b9de44c45
+SIZE (Jabber-Lite-0.8.tar.gz) = 48732
diff --git a/net-im/p5-Jabber-Lite/pkg-descr b/net-im/p5-Jabber-Lite/pkg-descr
new file mode 100644
index 000000000000..a85c6e159cf8
--- /dev/null
+++ b/net-im/p5-Jabber-Lite/pkg-descr
@@ -0,0 +1,5 @@
+Jabber::Lite is, as the name implies, a small 'lite' library for
+dealing with Jabber servers, implemented entirely in perl. Whilst it
+is small, it does try to be fairly complete for common tasks.
+
+WWW: http://search.cpan.org/dist/Jabber-Lite/
diff --git a/net-im/p5-Jabber-Lite/pkg-plist b/net-im/p5-Jabber-Lite/pkg-plist
new file mode 100644
index 000000000000..c7065eb32ee2
--- /dev/null
+++ b/net-im/p5-Jabber-Lite/pkg-plist
@@ -0,0 +1,6 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber/Lite/.packlist
+%%SITE_PERL%%/Jabber/Lite.pm
+@dirrmtry %%SITE_PERL%%/Jabber
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber/Lite
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Jabber