aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2017-02-08 01:43:59 +0800
committerkrion <krion@FreeBSD.org>2017-02-08 01:43:59 +0800
commitf635482ace22da06b4b6842231ff77690a75022e (patch)
treeb8103754bb230ae96b5213771394516ec3fe29e7 /net-im
parent23db829a15f795906955b8e47b5aec719e551437 (diff)
downloadfreebsd-ports-gnome-f635482ace22da06b4b6842231ff77690a75022e.tar.gz
freebsd-ports-gnome-f635482ace22da06b4b6842231ff77690a75022e.tar.zst
freebsd-ports-gnome-f635482ace22da06b4b6842231ff77690a75022e.zip
New port: net-im/py-toxcore-c
PyTox provides a Pythonic binding, i.e Object-oriented instead of C style, raise exception instead of returning error code. WWW: https://github.com/TokTok/py-toxcore-c PR: 216869 Submitted by: yuri@rawbw.com Approved by: mat (mentor) Differential Revision: https://reviews.freebsd.org/D9476
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/py-toxcore-c/Makefile30
-rw-r--r--net-im/py-toxcore-c/distinfo3
-rw-r--r--net-im/py-toxcore-c/pkg-descr4
4 files changed, 38 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 9e6e9c86af04..7983fc0c0539 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -140,6 +140,7 @@
SUBDIR += py-slackclient
SUBDIR += py-sleekxmpp
SUBDIR += py-telepot
+ SUBDIR += py-toxcore-c
SUBDIR += py-twistedWords
SUBDIR += py-xmpppy
SUBDIR += py-xmpppy-irc
diff --git a/net-im/py-toxcore-c/Makefile b/net-im/py-toxcore-c/Makefile
new file mode 100644
index 000000000000..97ff16099c50
--- /dev/null
+++ b/net-im/py-toxcore-c/Makefile
@@ -0,0 +1,30 @@
+# Created by: Yuri Victorovich
+# $FreeBSD$
+
+PORTNAME= toxcore-c
+PORTVERSION= 0.170206
+CATEGORIES= net-im net-p2p python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python binding for Project-Tox
+
+LICENSE= LGPL3
+LICENSE_FILE= ${WRKSRC}/LICENSE.md
+
+LIB_DEPENDS= libtoxcore.so:net-im/tox \
+ libsodium.so:security/libsodium \
+ libvpx.so:multimedia/libvpx \
+ libopus.so:audio/opus
+
+USE_GITHUB= yes
+GH_ACCOUNT= TokTok
+GH_PROJECT= py-toxcore-c
+GH_TAGNAME= ebced1f
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+CFLAGS+= -I${LOCALBASE}/include
+
+.include <bsd.port.mk>
diff --git a/net-im/py-toxcore-c/distinfo b/net-im/py-toxcore-c/distinfo
new file mode 100644
index 000000000000..dadbab01e213
--- /dev/null
+++ b/net-im/py-toxcore-c/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1486430415
+SHA256 (TokTok-py-toxcore-c-0.170206-ebced1f_GH0.tar.gz) = 9d5edf0991ee59835be4b6961792bd33b6f0d7703fb16827d9bf09b6f94610fc
+SIZE (TokTok-py-toxcore-c-0.170206-ebced1f_GH0.tar.gz) = 45529
diff --git a/net-im/py-toxcore-c/pkg-descr b/net-im/py-toxcore-c/pkg-descr
new file mode 100644
index 000000000000..73e955c710d9
--- /dev/null
+++ b/net-im/py-toxcore-c/pkg-descr
@@ -0,0 +1,4 @@
+PyTox provides a Pythonic binding, i.e Object-oriented instead of C style,
+raise exception instead of returning error code.
+
+WWW: https://github.com/TokTok/py-toxcore-c