aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-03-17 12:27:02 +0800
committermiwi <miwi@FreeBSD.org>2012-03-17 12:27:02 +0800
commit5966fe8a207458240c3688ffe68a0fe42ee22934 (patch)
tree49c72e1e41d785ca43557cd300e5180430d788ec /net-im
parent448273cfb9190d0be05b2d8a3e5029ab91b3c88b (diff)
downloadfreebsd-ports-gnome-5966fe8a207458240c3688ffe68a0fe42ee22934.tar.gz
freebsd-ports-gnome-5966fe8a207458240c3688ffe68a0fe42ee22934.tar.zst
freebsd-ports-gnome-5966fe8a207458240c3688ffe68a0fe42ee22934.zip
- Add missing BUILD_DEPENDS to silence build warnings and allow the port to work
- Sort DEPENDS - Avoid use of SITE_PERL in DEPENDS - Bump PORTREVISION PR: 165768 Submitted by: swills@ Feature safe: yes
Diffstat (limited to 'net-im')
-rw-r--r--net-im/p5-Net-XMPP2/Makefile30
1 files changed, 21 insertions, 9 deletions
diff --git a/net-im/p5-Net-XMPP2/Makefile b/net-im/p5-Net-XMPP2/Makefile
index 21e575c2363b..3c8ddd0eaa41 100644
--- a/net-im/p5-Net-XMPP2/Makefile
+++ b/net-im/p5-Net-XMPP2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Net-XMPP2
PORTVERSION= 0.14
+PORTREVISION= 1
CATEGORIES= net-im perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= Net
@@ -15,15 +16,26 @@ PKGNAMEPREFIX= p5-
MAINTAINER= miwi@FreeBSD.org
COMMENT= An implementation of the XMPP Protocol
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/${PERL_ARCH}/Net/LibIDN.pm:${PORTSDIR}/dns/p5-Net-LibIDN \
- ${SITE_PERL}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay \
- ${SITE_PERL}/${PERL_ARCH}/XML/Parser/Expat.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/${PERL_ARCH}/AnyEvent.pm:${PORTSDIR}/devel/p5-AnyEvent \
- ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL \
- ${SITE_PERL}/BS/Event.pm:${PORTSDIR}/devel/p5-BS-Event \
- ${SITE_PERL}/${PERL_ARCH}/Net/DNS.pm:${PORTSDIR}/dns/p5-Net-DNS \
- ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
+BUILD_DEPENDS= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+ p5-BS-Event>=0:${PORTSDIR}/devel/p5-BS-Event \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-Object-Event>=0:${PORTSDIR}/devel/p5-Object-Event \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
+RUN_DEPENDS:= p5-AnyEvent>=0:${PORTSDIR}/devel/p5-AnyEvent \
+ p5-Authen-SASL>=0:${PORTSDIR}/security/p5-Authen-SASL \
+ p5-BS-Event>=0:${PORTSDIR}/devel/p5-BS-Event \
+ p5-Digest-SHA1>=0:${PORTSDIR}/security/p5-Digest-SHA1 \
+ p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-Net-LibIDN>=0:${PORTSDIR}/dns/p5-Net-LibIDN \
+ p5-Net-SSLeay>=0:${PORTSDIR}/security/p5-Net-SSLeay \
+ p5-Object-Event>=0:${PORTSDIR}/devel/p5-Object-Event \
+ p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser \
+ p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
PERL_CONFIGURE= yes