aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2017-11-13 03:19:37 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 05:56:02 +0800
commit785cf130a75273de0f93c3e64bd960b5f1988d50 (patch)
tree72e3ded96b25203fd22cca4234dfb63b906a2962 /net-im
parentae25b3de6ba47c3c8aa1d63ac74c4f1bc2782db7 (diff)
downloadfreebsd-ports-gnome-785cf130a75273de0f93c3e64bd960b5f1988d50.tar.gz
freebsd-ports-gnome-785cf130a75273de0f93c3e64bd960b5f1988d50.tar.zst
freebsd-ports-gnome-785cf130a75273de0f93c3e64bd960b5f1988d50.zip
net-im/ricochet: add missing dependency (qt5-quickcontrols) and other changes
Other changes * Added the TOR option that will allow to disable the Tor dependency for people with alternative Tor installations * Fixed the SSL path PR: 223593 Reported by: Vinícius Zavam <egypcio@googlemail.com> Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D13027
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ricochet/Makefile23
1 files changed, 12 insertions, 11 deletions
diff --git a/net-im/ricochet/Makefile b/net-im/ricochet/Makefile
index 6cecec1f2c5e..fc329ea61624 100644
--- a/net-im/ricochet/Makefile
+++ b/net-im/ricochet/Makefile
@@ -4,10 +4,10 @@
PORTNAME= ricochet
PORTVERSION= 1.1.4
DISTVERSIONPREFIX= v
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net-im net-p2p
-MAINTAINER= yuri@rawbw.com
+MAINTAINER= yuri@FreeBSD.org
COMMENT= Anonymous peer-to-peer instant messenger
LICENSE= RICOCHET
@@ -16,29 +16,30 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LIB_DEPENDS= libprotobuf.so:devel/protobuf
-RUN_DEPENDS= tor:security/tor
-USE_GITHUB= yes
-GH_ACCOUNT= ricochet-im
+OPTIONS_DEFINE= TOR
+OPTIONS_DEFAULT= TOR
+TOR_DESC= Install Tor: it is required for ${PORTNAME} to run
USES= compiler:c++11-lib gmake pkgconfig qmake ssl
+USE_GITHUB= yes
+GH_ACCOUNT= ricochet-im
+USE_QT5= core gui multimedia network qml quick quickcontrols widgets \
+ buildtools_build linguisttools_build
USE_GL= gl
-USE_QT5= core gui network qml quick widgets multimedia buildtools_build linguisttools_build
-QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${LOCALBASE}
+QMAKE_ARGS+= DEFINES+=RICOCHET_NO_PORTABLE OPENSSLDIR=${OPENSSLBASE}
PLIST_FILES= bin/ricochet \
share/applications/ricochet.desktop \
share/icons/hicolor/48x48/apps/ricochet.png \
share/icons/hicolor/scalable/apps/ricochet.svg
+TOR_RUN_DEPENDS= tor:security/tor
+
.include <bsd.port.pre.mk>
post-patch:
@${REINPLACE_CMD} -E 's| -fsanitize=[a-z-]+| |g' \
${WRKSRC}/hardened.pri
-.if ${ARCH} == amd64 && ${OSREL:R} == 9
- @${REINPLACE_CMD} -E 's| -pie| |g' \
- ${WRKSRC}/hardened.pri
-.endif
.include <bsd.port.post.mk>