aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
committeralexbl <alexbl@FreeBSD.org>2007-07-30 17:42:28 +0800
commit7d749db4cf14f30613e9a53a08ffa3d3b4575146 (patch)
treead9062005432bbf28f5cce4ad3a1cd32a59dba69 /net-im
parent8e2da239f74a82ad1c98b69bd27abb3f4e40ecf3 (diff)
downloadfreebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.gz
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.tar.zst
freebsd-ports-gnome-7d749db4cf14f30613e9a53a08ffa3d3b4575146.zip
- Make Python 2.5.1 the default Python version
- Add significantly better support in bsd.python.mk for working with Python Eggs and the easy_install system Tested by: pointyhat runs Approved by: pav (portmgr) Most work by: perky Thanks to: pav
Diffstat (limited to 'net-im')
-rw-r--r--net-im/py-jabber/Makefile2
-rw-r--r--net-im/py-msnp/Makefile1
-rw-r--r--net-im/py-pyxmpp/Makefile3
-rw-r--r--net-im/py-twistedWords/Makefile1
4 files changed, 7 insertions, 0 deletions
diff --git a/net-im/py-jabber/Makefile b/net-im/py-jabber/Makefile
index d7ea7eab5a20..ecd9b79fab97 100644
--- a/net-im/py-jabber/Makefile
+++ b/net-im/py-jabber/Makefile
@@ -21,6 +21,8 @@ RUN_DEPENDS= ${PYEXPAT}
USE_PYTHON= yes
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= jabber.py
+PYDISTUTILS_PKGVERSION= 0.3-1
post-install:
@${ECHO} "jabber" > ${PYTHON_SITELIBDIR}/jabber.pth
diff --git a/net-im/py-msnp/Makefile b/net-im/py-msnp/Makefile
index f41b54bf47d4..d98a051924a1 100644
--- a/net-im/py-msnp/Makefile
+++ b/net-im/py-msnp/Makefile
@@ -19,6 +19,7 @@ COMMENT= MSN messaging in Python
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= msnp.py
.if !defined(NOPORTDOCS)
post-install:
diff --git a/net-im/py-pyxmpp/Makefile b/net-im/py-pyxmpp/Makefile
index 7ec5d55605f8..cd56d0a8ba02 100644
--- a/net-im/py-pyxmpp/Makefile
+++ b/net-im/py-pyxmpp/Makefile
@@ -24,6 +24,9 @@ USE_PYTHON= 2.3+
#USE_PYDISTUTILS= yes
USE_BZIP2= yes
+INSTALLS_EGGINFO= yes
+PYDISTUTILS_PKGVERSION= 1.0.0_svn
+
post-extract:
@${MKDIR} ${WRKSRC}/.svn
diff --git a/net-im/py-twistedWords/Makefile b/net-im/py-twistedWords/Makefile
index 6e1156a5f611..3da2727ad575 100644
--- a/net-im/py-twistedWords/Makefile
+++ b/net-im/py-twistedWords/Makefile
@@ -21,5 +21,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
USE_BZIP2= yes
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= Twisted_Words
.include <bsd.port.mk>