aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorleeym <leeym@FreeBSD.org>2005-04-26 01:52:27 +0800
committerleeym <leeym@FreeBSD.org>2005-04-26 01:52:27 +0800
commit949c2b21b132c039079559ec21329086a8c145a6 (patch)
treeb2e710f85767e47898f9e54bc4ef7e82f478dc3f /net-im
parent30e57d99af56d59ff96e24fa63f2db1c7e320716 (diff)
downloadfreebsd-ports-gnome-949c2b21b132c039079559ec21329086a8c145a6.tar.gz
freebsd-ports-gnome-949c2b21b132c039079559ec21329086a8c145a6.tar.zst
freebsd-ports-gnome-949c2b21b132c039079559ec21329086a8c145a6.zip
- Fixed linking againt -pthread and -lc_r
PR: 80307 Submitted by: Alexander Timoshenko <alexander.timoshenko@gmail.com> (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/jit/Makefile2
-rw-r--r--net-im/jit/files/patch-configure13
2 files changed, 15 insertions, 0 deletions
diff --git a/net-im/jit/Makefile b/net-im/jit/Makefile
index ec835d316ede..4256f4b0fc67 100644
--- a/net-im/jit/Makefile
+++ b/net-im/jit/Makefile
@@ -17,6 +17,8 @@ COMMENT= Jabber ICQ Transport
USE_GMAKE= yes
USE_REINPLACE= yes
HAS_CONFIGURE= yes
+MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
diff --git a/net-im/jit/files/patch-configure b/net-im/jit/files/patch-configure
new file mode 100644
index 000000000000..0638a435523e
--- /dev/null
+++ b/net-im/jit/files/patch-configure
@@ -0,0 +1,13 @@
+--- configure.orig Mon Apr 25 14:41:07 2005
++++ configure Mon Apr 25 14:42:05 2005
+@@ -60,8 +60,8 @@
+ CFLAGS="$CFLAGS -I/usr/include -fPIC"
+ LIBS="$LIBS -ldl -lpthread";;
+ FreeBSD)
+- CFLAGS="$CFLAGS -I/usr/local/include -I/usr/src/contrib/libstdc++ -D_THREAD_SAFE -DSUNOS"
+- LIBS="$LIBS -pthread -lcompat -lc_r -L/usr/local/lib -liconv";;
++ CFLAGS="$CFLAGS -I/usr/local/include -I/usr/src/contrib/libstdc++ \${PTHREAD_CFLAGS} -DSUNOS"
++ LIBS="$LIBS \${PTHREAD_LIBS} -lcompat -L/usr/local/lib -liconv";;
+ OpenBSD)
+ CFLAGS="$CFLAGS -I/usr/local/include -I/usr/src/contrib/libstdc++ -D_THREAD_SAFE -DSUNOS"
+ LIBS="$LIBS -pthread -lcompat -lc_r -L/usr/local/lib -liconv";;