aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-12-03 16:25:31 +0800
committerKoop Mast <kwm@rainbow-runner.nl>2018-02-04 06:03:30 +0800
commitd0057dc38d0c1eb2cd7a88769fb6c351f2370cfb (patch)
tree9f3ab381ea90cbc042acbf1b31c5ec90f97173a0 /net-im
parenteae70ae8015f859b5cdf713587d6d08aabd028e4 (diff)
downloadfreebsd-ports-gnome-d0057dc38d0c1eb2cd7a88769fb6c351f2370cfb.tar.gz
freebsd-ports-gnome-d0057dc38d0c1eb2cd7a88769fb6c351f2370cfb.tar.zst
freebsd-ports-gnome-d0057dc38d0c1eb2cd7a88769fb6c351f2370cfb.zip
- Add explicit FLAVOR to a few dependencies
- Remove FLAVOR from py-docutils dependency in comms/uhd, in this case it needs the rst2html command, not the docutils module - Mark some ports as not compatible with python3
Diffstat (limited to 'net-im')
-rw-r--r--net-im/emesene/Makefile16
-rw-r--r--net-im/telepathy-python/Makefile4
2 files changed, 10 insertions, 10 deletions
diff --git a/net-im/emesene/Makefile b/net-im/emesene/Makefile
index ab6d9aab454a..20a5a51f5322 100644
--- a/net-im/emesene/Makefile
+++ b/net-im/emesene/Makefile
@@ -12,13 +12,13 @@ COMMENT= Instant messenging client written in python
LICENSE= GPLv3+
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython \
- ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus \
- ${PYTHON_PKGNAMEPREFIX}notify>0:devel/py-notify \
- ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl \
- ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}webkitgtk>0:www/py-webkitgtk \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}notify>0:devel/py-notify@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}webkitgtk>0:www/py-webkitgtk@${PY_FLAVOR} \
xprop:x11/xprop
NO_ARCH= yes
@@ -26,7 +26,7 @@ NO_BUILD= yes
USE_GITHUB= yes
-USES= desktop-file-utils gettext-runtime python shebangfix
+USES= desktop-file-utils gettext-runtime python:2.7 shebangfix
USE_GNOME= pygtk2:run
USE_GSTREAMER= python
INSTALLS_ICONS= yes
diff --git a/net-im/telepathy-python/Makefile b/net-im/telepathy-python/Makefile
index bf68fd8d6aea..336b70f447c7 100644
--- a/net-im/telepathy-python/Makefile
+++ b/net-im/telepathy-python/Makefile
@@ -11,8 +11,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Python bindings for the Telepathy framework
-BUILD_DEPENDS= py2?-dbus>=0:devel/py-dbus
-RUN_DEPENDS= py2?-dbus>=0:devel/py-dbus
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>=0:devel/py-dbus@${PY_FLAVOR}
USES= gmake python:2
USE_GNOME= libxslt:build