aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-01-07 07:57:18 +0800
committermarcus <marcus@FreeBSD.org>2003-01-07 07:57:18 +0800
commitd895ae5fa3f79371f278b3dfe7a8f748c701dd65 (patch)
tree480724163697fc47d3a4d5af417c0ba7f58fab5e /net-im
parent5b65c7a9a333ec2ba4d74167427c7c3943ac36c0 (diff)
downloadfreebsd-ports-gnome-d895ae5fa3f79371f278b3dfe7a8f748c701dd65.tar.gz
freebsd-ports-gnome-d895ae5fa3f79371f278b3dfe7a8f748c701dd65.tar.zst
freebsd-ports-gnome-d895ae5fa3f79371f278b3dfe7a8f748c701dd65.zip
Fix the problem where users were unable to sign on to Yahoo, or were
signed on then immediately kicked off with a "Cannot read" error. Obtained from: Gaim CVS
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gaim/Makefile1
-rw-r--r--net-im/gaim/files/patch-src_protocols_yahoo_yahoo.c20
2 files changed, 21 insertions, 0 deletions
diff --git a/net-im/gaim/Makefile b/net-im/gaim/Makefile
index e69eafd7a77d..9b4f1090142d 100644
--- a/net-im/gaim/Makefile
+++ b/net-im/gaim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gaim
PORTVERSION= 0.59.7
+PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-im/gaim/files/patch-src_protocols_yahoo_yahoo.c b/net-im/gaim/files/patch-src_protocols_yahoo_yahoo.c
new file mode 100644
index 000000000000..f9eabbd409b6
--- /dev/null
+++ b/net-im/gaim/files/patch-src_protocols_yahoo_yahoo.c
@@ -0,0 +1,20 @@
+--- src/protocols/yahoo/yahoo.c.orig Sat Dec 7 12:54:15 2002
++++ src/protocols/yahoo/yahoo.c Mon Jan 6 18:48:24 2003
+@@ -87,6 +87,8 @@
+ #define USEROPT_PAGERPORT 4
+ #define YAHOO_PAGER_PORT 5050
+
++#define YAHOO_PROTO_VER 0x0900
++
+ enum yahoo_service { /* these are easier to see in hex */
+ YAHOO_SERVICE_LOGON = 1,
+ YAHOO_SERVICE_LOGOFF,
+@@ -352,7 +354,7 @@
+ data = g_malloc0(len + 1);
+
+ memcpy(data + pos, "YMSG", 4); pos += 4;
+- pos += yahoo_put16(data + pos, 0x0600);
++ pos += yahoo_put16(data + pos, YAHOO_PROTO_VER);
+ pos += yahoo_put16(data + pos, 0x0000);
+ pos += yahoo_put16(data + pos, pktlen);
+ pos += yahoo_put16(data + pos, pkt->service);