aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-05-10 06:18:59 +0800
committermandree <mandree@FreeBSD.org>2013-05-10 06:18:59 +0800
commitf5000841dd225ac030100cef08f1092fd6a11ff0 (patch)
tree231958f03863ee944cf1c76f20b4957f38cfab19 /net-im
parentfe514f0cf048b787ac736dd7b40c19358d31cefe (diff)
downloadfreebsd-ports-gnome-f5000841dd225ac030100cef08f1092fd6a11ff0.tar.gz
freebsd-ports-gnome-f5000841dd225ac030100cef08f1092fd6a11ff0.tar.zst
freebsd-ports-gnome-f5000841dd225ac030100cef08f1092fd6a11ff0.zip
Roll a newer upstream snapshot from SVN r659 (previous r628).
Changelog: https://code.google.com/p/skype4pidgin/source/list Clean up Makefile header. Prepare NLS, but upstream .pot/.po files are woefully out of date.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/pidgin-skype/Makefile41
-rw-r--r--net-im/pidgin-skype/distinfo4
-rw-r--r--net-im/pidgin-skype/pkg-plist14
3 files changed, 49 insertions, 10 deletions
diff --git a/net-im/pidgin-skype/Makefile b/net-im/pidgin-skype/Makefile
index c90aebc68073..662563190d4d 100644
--- a/net-im/pidgin-skype/Makefile
+++ b/net-im/pidgin-skype/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: pidgin-skype
-# Date created: 2010-12-19
-# Whom: mandree@FreeBSD.org
-#
+# Created by: mandree@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= pidgin-skype
-PORTVERSION= 0.0.0.628
-PORTREVISION= 1
+PORTVERSION= 0.0.0.659
CATEGORIES= net-im
MASTER_SITES= LOCAL/mandree
DISTFILES= pidgin-skype-svn-r${PORTVERSION:E}.tar.xz
@@ -46,9 +41,33 @@ mycflags= -shared -fPIC -DPIC ${PTHREAD_CFLAGS} \
-DPURPLE_PLUGINS
mylibs= ${PTHREAD_LIBS}
+USES= pkgconfig
+
+# DBUS: No DBUS here, does not work with Skype 2.1 beta
+# NLS: While the build works and enables translations,
+# the upstream translations and .pot file are woefully out of date.
+#OPTIONS_DEFINE= NLS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+mycflags+= -DENABLE_NLS
+mylibs+= -L${LOCALBASE}/lib -lintl
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+
+post-patch:
+ ${REINPLACE_CMD} 's/#undef ENABLE_NLS//' ${WRKSRC}/libskype.c
+.else
+PLIST_SUB+= NLS="@comment"
+.endif
+
do-build:
- cd ${WRKSRC} && ${CC} ${CFLAGS} ${mycflags} \
+ cd ${WRKSRC} && ${CC} ${CPPFLAGS} ${CFLAGS} ${mycflags} \
-o libskype.so libskype.c ${mylibs}
+.if ${PORT_OPTIONS:MNLS}
+ ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${_MAKE_JOBS} ${MAKE_ARGS} -C ${BUILD_WRKSRC} locales
+.endif
do-install:
${MKDIR} ${PREFIX}/lib/purple-2
@@ -61,5 +80,11 @@ do-install:
${WRKSRC}/icons/${i}/skype.png \
${PREFIX}/share/pixmaps/pidgin/protocols/${i}/
.endfor
+.if ${PORT_OPTIONS:MNLS}
+.for i in cs de en_AU es fr hu it ja mk nb pl pt pt_BR ru
+ ${MKDIR} ${PREFIX}/share/locale/${i}/LC_MESSAGES/
+ ${INSTALL_DATA} ${WRKSRC}/po/${i}.mo ${PREFIX}/share/locale/${i}/LC_MESSAGES/skype4pidgin.mo
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/net-im/pidgin-skype/distinfo b/net-im/pidgin-skype/distinfo
index 8827d0d96383..400cc7474740 100644
--- a/net-im/pidgin-skype/distinfo
+++ b/net-im/pidgin-skype/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pidgin-skype-svn-r628.tar.xz) = 14930415aaf4f7a6c10e9242e15a582b4db7f91c97ef8f6dbf3d154d69d1a794
-SIZE (pidgin-skype-svn-r628.tar.xz) = 124040
+SHA256 (pidgin-skype-svn-r659.tar.xz) = fb1a5e63cd76d7dec70aa0ca9350c60b05819e13917892ee3b9bcf951519c113
+SIZE (pidgin-skype-svn-r659.tar.xz) = 125352
diff --git a/net-im/pidgin-skype/pkg-plist b/net-im/pidgin-skype/pkg-plist
index 3bf1bce58dfa..3e4e452069b8 100644
--- a/net-im/pidgin-skype/pkg-plist
+++ b/net-im/pidgin-skype/pkg-plist
@@ -1,5 +1,19 @@
@comment $FreeBSD$
lib/purple-2/libskype.so
+%%NLS%%share/locale/cs/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/de/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/en_AU/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/es/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/it/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/mk/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/skype4pidgin.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/skype4pidgin.mo
share/pixmaps/pidgin/protocols/16/skypeout.png
share/pixmaps/pidgin/protocols/22/skypeout.png
share/pixmaps/pidgin/protocols/48/skypeout.png