aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-01-25 18:23:24 +0800
committergarga <garga@FreeBSD.org>2006-01-25 18:23:24 +0800
commitf5cdab066b52f20f459ae5d9ee0a11c1209008a2 (patch)
tree6e6c7df9046354868060010ae97b8d9dcc3fb605 /net-im
parent812a94cd71eae8524aa38cd52ed3c6e5e78d7732 (diff)
downloadfreebsd-ports-gnome-f5cdab066b52f20f459ae5d9ee0a11c1209008a2.tar.gz
freebsd-ports-gnome-f5cdab066b52f20f459ae5d9ee0a11c1209008a2.tar.zst
freebsd-ports-gnome-f5cdab066b52f20f459ae5d9ee0a11c1209008a2.zip
sendxmpp is a program to send XMPP (Jabber) messages from the command-line.
Messages can be sent both to individual recipients and chatrooms. WWW: http://www.djcbsoftware.nl/code/sendxmpp/ PR: ports/92254 Submitted by: Max E. Kuznecov <mek@mek.uz.ua>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/sendxmpp/Makefile33
-rw-r--r--net-im/sendxmpp/distinfo3
-rw-r--r--net-im/sendxmpp/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index a4e4b39cda99..d64e7c4eab09 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -97,6 +97,7 @@
SUBDIR += py-jabber
SUBDIR += py-twistedWords
SUBDIR += ruby-xmpp4r
+ SUBDIR += sendxmpp
SUBDIR += simicq
SUBDIR += sulci
SUBDIR += tik
diff --git a/net-im/sendxmpp/Makefile b/net-im/sendxmpp/Makefile
new file mode 100644
index 000000000000..f5e504b42253
--- /dev/null
+++ b/net-im/sendxmpp/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sendxmpp
+# Date created: 24 Jan 2006
+# Whom: Max E. Kuznecov <mek@mek.uz.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sendxmpp
+PORTVERSION= 0.0.8
+CATEGORIES= net-im perl5
+MASTER_SITES= http://www.djcbsoftware.nl/code/sendxmpp/
+
+MAINTAINER= mek@mek.uz.ua
+COMMENT= Perl-script to send xmpp (jabber) messages
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/XMPP.pm:${PORTSDIR}/net-im/p5-Net-XMPP
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= sendxmpp.1
+
+PLIST_FILES= bin/sendxmpp \
+ %%SITE_PERL%%/mach/auto/sendxmpp/.packlist
+PLIST_DIRS= %%SITE_PERL%%/mach/auto/sendxmpp
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Dependencies does not build on FreeBSD < 5.x
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/sendxmpp/distinfo b/net-im/sendxmpp/distinfo
new file mode 100644
index 000000000000..e16d33662228
--- /dev/null
+++ b/net-im/sendxmpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (sendxmpp-0.0.8.tar.gz) = 8a041f4940274f4d1e72e76fcc95e689
+SHA256 (sendxmpp-0.0.8.tar.gz) = 10e0a8d03f504f93ee4b9178c86f1882ac718e76d427602b1f9e10653cde0dde
+SIZE (sendxmpp-0.0.8.tar.gz) = 6401
diff --git a/net-im/sendxmpp/pkg-descr b/net-im/sendxmpp/pkg-descr
new file mode 100644
index 000000000000..4acfcf479462
--- /dev/null
+++ b/net-im/sendxmpp/pkg-descr
@@ -0,0 +1,4 @@
+sendxmpp is a program to send XMPP (Jabber) messages from the command-line.
+Messages can be sent both to individual recipients and chatrooms.
+
+WWW: http://www.djcbsoftware.nl/code/sendxmpp/