aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2014-08-16 05:32:57 +0800
committeradamw <adamw@FreeBSD.org>2014-08-16 05:32:57 +0800
commit2e1b664d973e047f31a3b7d227ade0dc91a063d5 (patch)
treeba8d813ecac753ed1118eca742ffd01db3df71d1 /net-im
parent53f4f05c28c6310d0ff89fdb42d41deeddadcebd (diff)
downloadfreebsd-ports-gnome-2e1b664d973e047f31a3b7d227ade0dc91a063d5.tar.gz
freebsd-ports-gnome-2e1b664d973e047f31a3b7d227ade0dc91a063d5.tar.zst
freebsd-ports-gnome-2e1b664d973e047f31a3b7d227ade0dc91a063d5.zip
Fix build on -current and fix shebangs.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centerim-devel/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-im/centerim-devel/Makefile b/net-im/centerim-devel/Makefile
index 288ad066b3f4..282a94bdbeb0 100644
--- a/net-im/centerim-devel/Makefile
+++ b/net-im/centerim-devel/Makefile
@@ -17,13 +17,18 @@ LICENSE= GPLv2
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
USE_PYTHON_RUN= yes
-USES= iconv gmake perl5 pkgconfig
+USES= iconv gmake perl5 pkgconfig shebangfix
USE_PERL5= run
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ssl --with-openssl
CONFLICTS= centericq-[0-9]* centerim-[0-9]*
+SHEBANG_FILES= misc/cimformathistory misc/cimextracthistory.pl
+SHEBANG_LANG= gawk
+gawk_OLD_CMD= /bin/gawk
+gawk_CMD= /usr/bin/awk
+
OPTIONS_DEFINE= NLS MULTIBYTE FRIBIDI MSN YAHOO AIM IRC JABBER GPGME RSS LJ GG
FRIBIDI_DESC= Fribidi Support
@@ -62,6 +67,8 @@ GPGME_CONFIGURE_OFF= --with-gpgme-prefix=/nonexistent
post-patch:
@${REINPLACE_CMD} -e 's|/var/run/screen|/tmp/screens|' \
${WRKSRC}/src/icqconf.cc
+ @${REINPLACE_CMD} -e 's|-R$$found_dir|-Wl,-rpath,$$found_dir|' \
+ ${WRKSRC}/configure
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}