aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2009-01-17 05:34:44 +0800
committermakc <makc@FreeBSD.org>2009-01-17 05:34:44 +0800
commit31de78163017740a66cd865a5a0749c3e36538ed (patch)
treef811dc812f98874687f409b17c60cf5e18d20f15 /net-im
parentb99b96f4095aae5f29c01a339f3d330f533f6eb4 (diff)
downloadfreebsd-ports-gnome-31de78163017740a66cd865a5a0749c3e36538ed.tar.gz
freebsd-ports-gnome-31de78163017740a66cd865a5a0749c3e36538ed.tar.zst
freebsd-ports-gnome-31de78163017740a66cd865a5a0749c3e36538ed.zip
Fix build on amd64.
PR: ports/130197 Submitted by: Matt Tosto <datahead4 at gmail.com> (maintainer) Approved by: miwi (mentor)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libmsn/Makefile1
-rw-r--r--net-im/libmsn/files/patch-msn__util.cpp26
-rw-r--r--net-im/libmsn/files/patch-msntest__CMakeLists.txt11
3 files changed, 27 insertions, 11 deletions
diff --git a/net-im/libmsn/Makefile b/net-im/libmsn/Makefile
index fc9994b905f4..414da062c359 100644
--- a/net-im/libmsn/Makefile
+++ b/net-im/libmsn/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libmsn
DISTVERSION= 4.0-beta2
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= SF
diff --git a/net-im/libmsn/files/patch-msn__util.cpp b/net-im/libmsn/files/patch-msn__util.cpp
new file mode 100644
index 000000000000..40d202ae8017
--- /dev/null
+++ b/net-im/libmsn/files/patch-msn__util.cpp
@@ -0,0 +1,26 @@
+--- ./msn/util.cpp.orig 2008-11-16 16:27:05.000000000 +0300
++++ ./msn/util.cpp 2009-01-16 20:32:29.000000000 +0300
+@@ -29,7 +29,7 @@
+ #include <fstream>
+ #include <openssl/rand.h>
+ #include <cstring>
+-#include <sys/timeb.h>
++#include <sys/time.h>
+ #include "md5.h"
+
+ #ifdef _WIN32
+@@ -352,10 +352,11 @@
+
+ std::string new_branch()
+ {
+- struct timeb t;
+- ftime(&t);
++ struct timeval t;
++ struct timezone tz;
++ gettimeofday(&t, &tz);
+ char branch[100];
+- srand(t.millitm);
++ srand(t.tv_usec);
+ unsigned int a=random();
+ srand(a);
+ unsigned short b=random();
diff --git a/net-im/libmsn/files/patch-msntest__CMakeLists.txt b/net-im/libmsn/files/patch-msntest__CMakeLists.txt
deleted file mode 100644
index 7c9fe10d25fd..000000000000
--- a/net-im/libmsn/files/patch-msntest__CMakeLists.txt
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./msntest/CMakeLists.txt.orig 2008-11-13 03:41:03.000000000 +0300
-+++ ./msntest/CMakeLists.txt 2008-12-28 22:10:09.000000000 +0300
-@@ -3,7 +3,7 @@
- )
-
- add_executable (msntest ${msntest_SRCS} )
--target_link_libraries(msntest crypto msn ssl)
-+target_link_libraries(msntest crypto msn ssl compat)
-
- ########### install files ###############
- install(TARGETS msntest DESTINATION ${CMAKE_INSTALL_PREFIX}/bin)