aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-03-07 06:52:36 +0800
committernivit <nivit@FreeBSD.org>2013-03-07 06:52:36 +0800
commit37e118320ce79da54db42d139b922ffbb578e84c (patch)
tree622801cc05380868195c55a9a7d34c62eb4225b1 /net-im
parent7468987af123f305cc56043fcefb29354ef383ae (diff)
downloadfreebsd-ports-gnome-37e118320ce79da54db42d139b922ffbb578e84c.tar.gz
freebsd-ports-gnome-37e118320ce79da54db42d139b922ffbb578e84c.tar.zst
freebsd-ports-gnome-37e118320ce79da54db42d139b922ffbb578e84c.zip
Jreen is extensible Qt-based asynchronious Jabber library.
WWW: https://github.com/euroelessar/jreen
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/jreen/Makefile35
-rw-r--r--net-im/jreen/distinfo2
-rw-r--r--net-im/jreen/files/patch-CMakeLists.txt11
-rw-r--r--net-im/jreen/pkg-descr3
-rw-r--r--net-im/jreen/pkg-plist71
6 files changed, 123 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 1e069ef0aed1..635ac314be39 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -48,6 +48,7 @@
SUBDIR += jabberd
SUBDIR += jarl
SUBDIR += jggtrans
+ SUBDIR += jreen
SUBDIR += kmerlin
SUBDIR += kmess
SUBDIR += kmess-kde4
diff --git a/net-im/jreen/Makefile b/net-im/jreen/Makefile
new file mode 100644
index 000000000000..ac14f391a20b
--- /dev/null
+++ b/net-im/jreen/Makefile
@@ -0,0 +1,35 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jreen
+PORTVERSION= 1.1.1
+#PORTREVISION= 0
+CATEGORIES= net-im
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Extensible Qt-based asynchronious Jabber library
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= qca:${PORTSDIR}/devel/qca \
+ speex:${PORTSDIR}/audio/speex
+
+CMAKE_ARGS= -DCMAKE_COLOR_MAKEFILE:BOOL="OFF"
+
+GH_ACCOUNT= euroelessar
+GH_COMMIT= 388621f
+GH_PROJECT= jreen
+GH_TAGNAME= v${PORTVERSION}
+
+REINPLACE_ARGS= -e 's,-lspeex,-L${LOCALBASE}/lib &,1' -i.bak
+
+USE_CMAKE= yes
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+USE_QT4= moc_build qmake_build rcc_build network
+
+post-configure:
+ @${REINPLACE_CMD} ${WRKSRC}/CMakeFiles/jreen.dir/link.txt
+
+.include <bsd.port.mk>
diff --git a/net-im/jreen/distinfo b/net-im/jreen/distinfo
new file mode 100644
index 000000000000..a91da00613c2
--- /dev/null
+++ b/net-im/jreen/distinfo
@@ -0,0 +1,2 @@
+SHA256 (jreen-1.1.1.tar.gz) = 7ecd2e4960caa47ca0632efbe234b3623865a7dd128040aaa448dd0747b5e439
+SIZE (jreen-1.1.1.tar.gz) = 292173
diff --git a/net-im/jreen/files/patch-CMakeLists.txt b/net-im/jreen/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..1aee6186b6a7
--- /dev/null
+++ b/net-im/jreen/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- ./CMakeLists.txt.orig 2013-02-13 23:28:31.000000000 +0100
++++ ./CMakeLists.txt 2013-02-13 23:28:47.000000000 +0100
+@@ -217,7 +217,7 @@
+ ${CMAKE_CURRENT_BINARY_DIR}/libjreen.pc
+ )
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/libjreen.pc
+- DESTINATION lib${LIB_SUFFIX}/pkgconfig
++ DESTINATION libdata/pkgconfig
+ )
+ endif(NOT WIN32)
+
diff --git a/net-im/jreen/pkg-descr b/net-im/jreen/pkg-descr
new file mode 100644
index 000000000000..3e9b2e02e7cc
--- /dev/null
+++ b/net-im/jreen/pkg-descr
@@ -0,0 +1,3 @@
+Jreen is extensible Qt-based asynchronious Jabber library.
+
+WWW: https://github.com/euroelessar/jreen
diff --git a/net-im/jreen/pkg-plist b/net-im/jreen/pkg-plist
new file mode 100644
index 000000000000..fdc449d837f4
--- /dev/null
+++ b/net-im/jreen/pkg-plist
@@ -0,0 +1,71 @@
+@comment $FreeBSD$
+include/jreen/abstractroster.h
+include/jreen/activity.h
+include/jreen/attention.h
+include/jreen/bitsofbinary.h
+include/jreen/bookmark.h
+include/jreen/bookmarkstorage.h
+include/jreen/buffereddatastream.h
+include/jreen/capabilities.h
+include/jreen/captcha.h
+include/jreen/chatstate.h
+include/jreen/client.h
+include/jreen/connection.h
+include/jreen/connectionbosh.h
+include/jreen/dataform.h
+include/jreen/datastream.h
+include/jreen/delayeddelivery.h
+include/jreen/directconnection.h
+include/jreen/disco.h
+include/jreen/entitytime.h
+include/jreen/error.h
+include/jreen/experimental/iristransport.h
+include/jreen/experimental/jingleaudiocontent.h
+include/jreen/experimental/jingleaudiopayload.h
+include/jreen/experimental/jinglecontent.h
+include/jreen/experimental/jinglemanager.h
+include/jreen/experimental/jinglesession.h
+include/jreen/experimental/jingletransport.h
+include/jreen/forwarded.h
+include/jreen/iq.h
+include/jreen/iqreply.h
+include/jreen/jid.h
+include/jreen/jreen.h
+include/jreen/jstrings.h
+include/jreen/langmap.h
+include/jreen/logger.h
+include/jreen/message.h
+include/jreen/messagesession.h
+include/jreen/metacontactstorage.h
+include/jreen/mood.h
+include/jreen/mucroom.h
+include/jreen/nickname.h
+include/jreen/parser.h
+include/jreen/pgpencrypted.h
+include/jreen/pgpsigned.h
+include/jreen/ping.h
+include/jreen/presence.h
+include/jreen/privacymanager.h
+include/jreen/privatexml.h
+include/jreen/pubsubevent.h
+include/jreen/pubsubmanager.h
+include/jreen/receipt.h
+include/jreen/registrationmanager.h
+include/jreen/softwareversion.h
+include/jreen/stanza.h
+include/jreen/stanzaextension.h
+include/jreen/streamprocessor.h
+include/jreen/subscription.h
+include/jreen/tcpconnection.h
+include/jreen/tune.h
+include/jreen/udpconnection.h
+include/jreen/util.h
+include/jreen/vcard.h
+include/jreen/vcardmanager.h
+include/jreen/vcardupdate.h
+lib/libjreen.so
+lib/libjreen.so.1
+lib/libjreen.so.1.1.1
+libdata/pkgconfig/libjreen.pc
+@dirrm include/jreen/experimental
+@dirrm include/jreen