aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-06-23 04:34:50 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-06-23 04:34:50 +0800
commit4d777003ec0b41d8b9b7a83432d4200f5be8a054 (patch)
tree07b6452db4cda0960e1396f304e5ae69c40c4914 /net-im
parent134fd102f6762b5ef95cf20f692aaf810e793f67 (diff)
downloadfreebsd-ports-gnome-4d777003ec0b41d8b9b7a83432d4200f5be8a054.tar.gz
freebsd-ports-gnome-4d777003ec0b41d8b9b7a83432d4200f5be8a054.tar.zst
freebsd-ports-gnome-4d777003ec0b41d8b9b7a83432d4200f5be8a054.zip
Freetalk is a console based Jabber client. It features a readline interface
with completion of buddy names, commands, and even ordinary English words. Freetalk is extensible, configurable, and scriptable through a Guile interface. WWW: http://www.gnu.org/software/freetalk/ PR: 135897 Submitted by: Oleg Ginzburg <oleg.ginzburg@nevosoft.ru>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/freetalk/Makefile46
-rw-r--r--net-im/freetalk/distinfo3
-rw-r--r--net-im/freetalk/pkg-descr5
-rw-r--r--net-im/freetalk/pkg-plist36
5 files changed, 91 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index a607bd1735b3..b4325f336f97 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -29,6 +29,7 @@
SUBDIR += farsight2
SUBDIR += finch
SUBDIR += firetalk
+ SUBDIR += freetalk
SUBDIR += fugu
SUBDIR += gajim
SUBDIR += gajim-devel
diff --git a/net-im/freetalk/Makefile b/net-im/freetalk/Makefile
new file mode 100644
index 000000000000..0a63326c67f3
--- /dev/null
+++ b/net-im/freetalk/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: freetalk
+# Date created: 19 June 2009
+# Whom: Oleg Ginzburg (oleg.ginzburg@nevosoft.ru)
+#
+# $FreeBSD$
+#
+
+PORTNAME= freetalk
+PORTVERSION= 3.2
+CATEGORIES= net-im
+MASTER_SITES= SAVANNAH/freetalk \
+ http://itdev.spb.ru/mirror/
+
+MAINTAINER= oleg.ginzburg@nevosoft.ru
+COMMENT= GNU console based Jabber client
+
+LIB_DEPENDS= loudmouth-1.0:${PORTSDIR}/net-im/loudmouth
+BUILD_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
+RUN_DEPENDS= guile>=1.8.6:${PORTSDIR}/lang/guile
+
+USE_GNOME= pkgconfig glib20
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+
+MAN1= freetalk.1
+INFO= freetalk
+
+OPTIONS= BEEP "Use beep program" off
+
+.if !defined(WITHOUT_NLS)
+PLIST_SUB+= NLS=""
+USE_GETTEXT= yes
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_BEEP)
+RUN_DEPENDS+= ${LOCALBASE}/bin/beep:${PORTSDIR}/audio/beep
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-im/freetalk/distinfo b/net-im/freetalk/distinfo
new file mode 100644
index 000000000000..acb0352be2be
--- /dev/null
+++ b/net-im/freetalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (freetalk-3.2.tar.gz) = ab09bd07dde158551f151d281b14642c
+SHA256 (freetalk-3.2.tar.gz) = ba4a70052d94293a3c073828ca1993bde97d3f3f47554b65ceba9799a43fb689
+SIZE (freetalk-3.2.tar.gz) = 360291
diff --git a/net-im/freetalk/pkg-descr b/net-im/freetalk/pkg-descr
new file mode 100644
index 000000000000..727b42550458
--- /dev/null
+++ b/net-im/freetalk/pkg-descr
@@ -0,0 +1,5 @@
+Freetalk is a console based Jabber client. It features a readline interface
+with completion of buddy names, commands, and even ordinary English words.
+Freetalk is extensible, configurable, and scriptable through a Guile interface.
+
+WWW: http://www.gnu.org/software/freetalk/
diff --git a/net-im/freetalk/pkg-plist b/net-im/freetalk/pkg-plist
new file mode 100644
index 000000000000..4799d9285641
--- /dev/null
+++ b/net-im/freetalk/pkg-plist
@@ -0,0 +1,36 @@
+bin/freetalk
+%%DOCSDIR%%/examples/daemon.ft
+%%DOCSDIR%%/examples/freetalk.scm
+%%DOCSDIR%%/examples/hello-world.ft
+%%DOCSDIR%%/examples/mimic.ft
+%%DATADIR%%/extensions/beep.scm
+%%DATADIR%%/extensions/broadcast.scm
+%%DATADIR%%/extensions/color.scm
+%%DATADIR%%/extensions/connection.scm
+%%DATADIR%%/extensions/dict-buddy.scm
+%%DATADIR%%/extensions/dyn-commands.scm
+%%DATADIR%%/extensions/file-transfer.scm
+%%DATADIR%%/extensions/first-time-run.sh
+%%DATADIR%%/extensions/hacker-romance.scm
+%%DATADIR%%/extensions/history.scm
+%%DATADIR%%/extensions/init.scm
+%%DATADIR%%/extensions/login.scm
+%%DATADIR%%/extensions/loudscream.scm
+%%DATADIR%%/extensions/mr-oxford.scm
+%%DATADIR%%/extensions/pipe.scm
+%%DATADIR%%/extensions/proud-of-freetalk.scm
+%%DATADIR%%/extensions/roster.scm
+%%DATADIR%%/extensions/shell.scm
+%%DATADIR%%/extensions/state.scm
+%%DATADIR%%/extensions/url.scm
+%%DATADIR%%/extensions/utils.scm
+share/locale/en@boldquot/LC_MESSAGES/freetalk.mo
+share/locale/en@quot/LC_MESSAGES/freetalk.mo
+@dirrmtry share/locale/en@boldquot/LC_MESSAGES
+@dirrmtry share/locale/en@boldquot
+@dirrmtry share/locale/en@quot/LC_MESSAGES
+@dirrmtry share/locale/en@quot
+@dirrm %%DATADIR%%/extensions
+@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/examples
+@dirrm %%DOCSDIR%%