aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
committermat <mat@FreeBSD.org>2016-06-16 21:23:13 +0800
commita4af234af8f51d40eb998ed6d368ccea401a3302 (patch)
treef5237f7173e7b9a5cbac11e6a57f460d84e79314 /net-im
parent56be8553fe553c4526347278fbdd90ec4156eb14 (diff)
downloadfreebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.gz
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.tar.zst
freebsd-ports-gnome-a4af234af8f51d40eb998ed6d368ccea401a3302.zip
Fix usage of WITH_OPENSSL_BASE, WITH_OPENSSL_PORT and OPENSSL_PORT.
WITH_OPENSSL_* can't be set after bsd.port.pre.mk. Fold all other usage into using SSL_DEFAULT == foo PR: 210149 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6577
Diffstat (limited to 'net-im')
-rw-r--r--net-im/telepathy-gabble/Makefile6
-rw-r--r--net-im/telepathy-idle/Makefile2
2 files changed, 5 insertions, 3 deletions
diff --git a/net-im/telepathy-gabble/Makefile b/net-im/telepathy-gabble/Makefile
index 1b8e448ba771..db27193595cf 100644
--- a/net-im/telepathy-gabble/Makefile
+++ b/net-im/telepathy-gabble/Makefile
@@ -33,7 +33,9 @@ INSTALL_TARGET= install-strip
PLIST_SUB= PVERSION=${PORTVERSION}
-.if defined(WITH_OPENSSL_BASE)
+.include <bsd.port.pre.mk>
+
+.if ${SSL_DEFAULT} == base
CONFIGURE_ENV+= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/include"
.endif
@@ -41,4 +43,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|-Werror||g' \
${WRKSRC}/lib/ext/wocky/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net-im/telepathy-idle/Makefile b/net-im/telepathy-idle/Makefile
index b20a1ee5dc02..48c2d878757b 100644
--- a/net-im/telepathy-idle/Makefile
+++ b/net-im/telepathy-idle/Makefile
@@ -23,7 +23,7 @@ INSTALL_TARGET= install-strip
.include <bsd.port.pre.mk>
-.if defined(WITH_OPENSSL_BASE)
+.if ${SSL_DEFAULT} == base
CONFIGURE_ENV+= OPENSSL_LIBS="-L/usr/lib -lssl -lcrypto" OPENSSL_CFLAGS="-I/usr/include"
.endif