aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2013-03-25 18:22:14 +0800
committergarga <garga@FreeBSD.org>2013-03-25 18:22:14 +0800
commiteeabeaac30b94b20e422a180ae8a7c15a4a3c1e4 (patch)
treeba6023e324973cfa6c40974c1ccb19d0b47a301f /net-im
parent8251a02838a249527061f249df70cc47f44a128c (diff)
downloadfreebsd-ports-gnome-eeabeaac30b94b20e422a180ae8a7c15a4a3c1e4.tar.gz
freebsd-ports-gnome-eeabeaac30b94b20e422a180ae8a7c15a4a3c1e4.tar.zst
freebsd-ports-gnome-eeabeaac30b94b20e422a180ae8a7c15a4a3c1e4.zip
Allow twirssi to use development version of irssi
PR: ports/177360 Submitted by: gjb@
Diffstat (limited to 'net-im')
-rw-r--r--net-im/twirssi/Makefile21
1 files changed, 18 insertions, 3 deletions
diff --git a/net-im/twirssi/Makefile b/net-im/twirssi/Makefile
index 98144b40bd32..4ff646e587dd 100644
--- a/net-im/twirssi/Makefile
+++ b/net-im/twirssi/Makefile
@@ -10,11 +10,26 @@ EXTRACT_ONLY=
MAINTAINER= garga@FreeBSD.org
COMMENT= Twitter script to irssi
-RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi \
- p5-Net-Twitter>=0:${PORTSDIR}/net/p5-Net-Twitter \
+RUN_DEPENDS= p5-Net-Twitter>=0:${PORTSDIR}/net/p5-Net-Twitter \
p5-WWW-Shorten>=0:${PORTSDIR}/www/p5-WWW-Shorten \
p5-WWW-Shorten-Bitly>=0:${PORTSDIR}/www/p5-WWW-Shorten-Bitly
+OPTIONS_SINGLE= IRSSIVER
+OPTIONS_SINGLE_IRSSIVER=PROD DEVEL
+OPTIONS_DEFAULT=PROD
+PROD_DESC= Use production irc/irssi port
+DEVEL_DESC= Use development irc/irssi-devel port
+
+.include <bsd.port.pre.mk>
+
+.if ${PORT_OPTIONS:MPROD}
+RUN_DEPENDS+= irssi:${PORTSDIR}/irc/irssi
+.endif
+
+.if ${PORT_OPTIONS:MPROD}
+RUN_DEPENDS+= irssi:${PORTSDIR}/irc/irssi-devel
+.endif
+
SUB_FILES= pkg-message
NO_BUILD= yes
@@ -31,4 +46,4 @@ do-install:
@${INSTALL_SCRIPT} -v ${WRKSRC}/${PORTNAME}.pl ${DATADIR}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>