aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-12-12 21:01:40 +0800
committerbapt <bapt@FreeBSD.org>2013-12-12 21:01:40 +0800
commitf9d4be6cb76f701b71c67b907d31d6e209455b3a (patch)
tree4001d5f3f8ce7ed1c00ed7855c9522129d5a9fe7 /net-im
parent145bf2bd9f4df368ec9bf802b02f2914d2d378ad (diff)
downloadfreebsd-ports-gnome-f9d4be6cb76f701b71c67b907d31d6e209455b3a.tar.gz
freebsd-ports-gnome-f9d4be6cb76f701b71c67b907d31d6e209455b3a.tar.zst
freebsd-ports-gnome-f9d4be6cb76f701b71c67b907d31d6e209455b3a.zip
Convert LIB_DEPENDS for ports depending on boost
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq-icq/Makefile2
-rw-r--r--net-im/licq-jabber/Makefile4
-rw-r--r--net-im/licq-msn/Makefile2
-rw-r--r--net-im/licq-osd/Makefile4
-rw-r--r--net-im/licq-qt-gui/Makefile2
5 files changed, 7 insertions, 7 deletions
diff --git a/net-im/licq-icq/Makefile b/net-im/licq-icq/Makefile
index c2f2dc09e2ce..31c7471db0eb 100644
--- a/net-im/licq-icq/Makefile
+++ b/net-im/licq-icq/Makefile
@@ -9,7 +9,7 @@ COMMENT= ICQ plugin for Licq
LICENSE= GPLv2
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
USES= cmake
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/net-im/licq-jabber/Makefile b/net-im/licq-jabber/Makefile
index 55b1854d5066..3ea74799f13b 100644
--- a/net-im/licq-jabber/Makefile
+++ b/net-im/licq-jabber/Makefile
@@ -9,8 +9,8 @@ COMMENT= Jabber (XMPP) plugin for Licq
LICENSE= GPLv2
-LIB_DEPENDS= gloox:${PORTSDIR}/net-im/gloox \
- boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libgloox.so:${PORTSDIR}/net-im/gloox \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs
NO_STAGE= yes
diff --git a/net-im/licq-msn/Makefile b/net-im/licq-msn/Makefile
index 4798fe3530c6..1a1cc20a5406 100644
--- a/net-im/licq-msn/Makefile
+++ b/net-im/licq-msn/Makefile
@@ -9,7 +9,7 @@ COMMENT= MSN plugin for Licq
LICENSE= GPLv2
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
NO_STAGE= yes
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index f971996cb81a..eda7f2da7182 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -9,8 +9,8 @@ CATEGORIES= net-im
MAINTAINER= dinoex@FreeBSD.org
COMMENT= OnScreenDisplay messages in licq
-LIB_DEPENDS= xosd:${PORTSDIR}/misc/xosd \
- boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libxosd.so:${PORTSDIR}/misc/xosd \
+ libboost_regex.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/lib/licq/licq_qt4-gui.so:${PORTSDIR}/${LICQ_PORT}-qt-gui
# run dependency may be too strict, delete it if you use another
# plugin (gtk+) and wish run osd with it. i've not tested with
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index cb8e533125e5..9d4c1b743051 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -11,7 +11,7 @@ COMMENT= Qt plugin for licq
LICENSE= GPLv2
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
RUN_DEPENDS= ${LOCALBASE}/lib/licq/protocol_icq.so:${PORTSDIR}/${LICQ_PORT}-icq
NO_STAGE= yes