aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2009-07-23 00:27:08 +0800
committerpgollucci <pgollucci@FreeBSD.org>2009-07-23 00:27:08 +0800
commit27d060e940214a9ebd7dcd86f654fc16c995ecc4 (patch)
treeaec683b12f2f81d4f1c216cd26fc44084467dc0a /net-im
parentd3b2f0724a28b64f0093e07bfa19d56a8e44b1f2 (diff)
downloadfreebsd-ports-gnome-27d060e940214a9ebd7dcd86f654fc16c995ecc4.tar.gz
freebsd-ports-gnome-27d060e940214a9ebd7dcd86f654fc16c995ecc4.tar.zst
freebsd-ports-gnome-27d060e940214a9ebd7dcd86f654fc16c995ecc4.zip
- lang/perl5.6 is dead, remove PERL_LEVEL/PERL_VERSION < 500801 checks
PR: ports/135398 Tested by: 2 -exp runs by pav Approved by: portmgr (pav)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/libpurple/Makefile5
-rw-r--r--net-im/p5-Jabber-Lite/Makefile9
-rw-r--r--net-im/p5-Net-OSCAR/Makefile11
-rw-r--r--net-im/p5-Net-XMPP2/Makefile8
-rw-r--r--net-im/vicq/Makefile16
5 files changed, 10 insertions, 39 deletions
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index 41880ba2a158..a228bafe382c 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -183,7 +183,7 @@ CONFIGURE_ARGS+= --disable-dbus
PLIST_SUB+= DBUS="@comment not installed: "
.endif
-.if defined(WITH_PERL) && ${PERL_LEVEL} >= 500800
+.if defined(WITH_PERL)
USE_PERL5= yes
CONFIGURE_ARGS+= --with-perl-lib=site
PLIST_SUB+= PERL:=""
@@ -293,9 +293,6 @@ PLIST_SUB+= ZEPHYR="@comment not installed: "
.endif
pre-everything::
-.if defined(WITH_PERL) && ${PERL_LEVEL} < 500800
- @${ECHO_MSG} "WARNING: Perl scripting disabled (Perl 5.8 requirement not met)."
-.endif
.if defined(WITHOUT_GNUTLS) && defined(WITHOUT_NSS)
@${ECHO_MSG} "WARNING: In order to use MSN, you must enable the GNUTLS and/or NSS options."
.endif
diff --git a/net-im/p5-Jabber-Lite/Makefile b/net-im/p5-Jabber-Lite/Makefile
index b7dc53ea7b18..bcaac5501ce2 100644
--- a/net-im/p5-Jabber-Lite/Makefile
+++ b/net-im/p5-Jabber-Lite/Makefile
@@ -23,11 +23,4 @@ PERL_CONFIGURE= yes
MAN3= Jabber::Lite.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-OSCAR/Makefile b/net-im/p5-Net-OSCAR/Makefile
index ca17c68da648..706925e60a09 100644
--- a/net-im/p5-Net-OSCAR/Makefile
+++ b/net-im/p5-Net-OSCAR/Makefile
@@ -33,13 +33,4 @@ MAN3= Net::OSCAR.3 \
Net::OSCAR::XML.3 \
Net::OSCAR::_BLInternal.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-XMPP2/Makefile b/net-im/p5-Net-XMPP2/Makefile
index a7a1c0d3fdb8..fe8203efdb05 100644
--- a/net-im/p5-Net-XMPP2/Makefile
+++ b/net-im/p5-Net-XMPP2/Makefile
@@ -76,10 +76,4 @@ MAN3= Net::XMPP2.3 \
Net::XMPP2::Util.3 \
Net::XMPP2::Writer.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/vicq/Makefile b/net-im/vicq/Makefile
index 3137b191d01c..7f7383ba757b 100644
--- a/net-im/vicq/Makefile
+++ b/net-im/vicq/Makefile
@@ -21,23 +21,19 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PERL_CONFIGURE= yes
+SIGNAL_PATCH=p5.8-patch-sigalrm
post-extract:
${MV} ${WRKSRC}/Net/vICQ/* ${WRKSRC}
${RM} ${WRKSRC}/install.pl
+post-patch:
+ @${ECHO_MSG} "===> Applying patch ${SIGNAL_PATCH} for ${PKGNAME}"
+ @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/${SIGNAL_PATCH}
+
post-install:
${INSTALL_SCRIPT} ${WRKSRC}/vicq ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/examples/vicq
${INSTALL_DATA} ${WRKSRC}/vicqrc.example ${PREFIX}/share/examples/vicq
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} >= 500800
-SIGNAL_PATCH=p5.8-patch-sigalrm
-post-patch:
- @${ECHO_MSG} "===> Applying patch ${SIGNAL_PATCH} for ${PKGNAME}"
- @${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/${SIGNAL_PATCH}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>