aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2013-10-02 16:38:57 +0800
committermarino <marino@FreeBSD.org>2013-10-02 16:38:57 +0800
commit0a5f04a51ca49ccc7e422f04f6d059a8200215ea (patch)
tree6c3304cbd4627303b1018eceb76572c824082738 /net-im
parent3e6804d4850a8e4d04e5d9585e1927619bbdd5fc (diff)
downloadfreebsd-ports-gnome-0a5f04a51ca49ccc7e422f04f6d059a8200215ea.tar.gz
freebsd-ports-gnome-0a5f04a51ca49ccc7e422f04f6d059a8200215ea.tar.zst
freebsd-ports-gnome-0a5f04a51ca49ccc7e422f04f6d059a8200215ea.zip
net-im/qutim: add <unistd.h> for modern compilers, fix binutils
In addition to the header inclusion, the linking stage failed on modern binutils because libX11 was used without being explicitly listed. The LDFLAGS from the Makefile were getting overwritten by the CMake makefile, so that had to be patch to allow the LDFLAGS to be appended. Approved by: portmgr (bapt, implicit)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/qutim/Makefile3
-rw-r--r--net-im/qutim/files/patch-CMakeLists.txt11
-rw-r--r--net-im/qutim/files/patch-src_3rdparty_qtsolutions_qtlocalpeer.cpp10
3 files changed, 23 insertions, 1 deletions
diff --git a/net-im/qutim/Makefile b/net-im/qutim/Makefile
index 1beaa39660d2..23f75a05f76c 100644
--- a/net-im/qutim/Makefile
+++ b/net-im/qutim/Makefile
@@ -11,7 +11,7 @@ MASTER_SITES= http://dl.kibab.com/distfiles/qutim/ \
DISTNAME= qutim_${PORTVERSION}_svn529
MAINTAINER= webmaster@kibab.com
-COMMENT= A Qt4-based multiprotocol IM client with advanced features
+COMMENT= Qt4-based multiprotocol IM client with advanced features
USE_QT4= designer_build \
gui \
@@ -29,6 +29,7 @@ USE_XORG= xscrnsaver
USES= cmake
CMAKE_ARGS+= -DUNIX:BOOL=1 -DBSD:BOOL=1
+LDFLAGS+= -L${LOCALBASE}/lib -lX11
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/net-im/qutim/files/patch-CMakeLists.txt b/net-im/qutim/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..c0be798c0c8d
--- /dev/null
+++ b/net-im/qutim/files/patch-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2009-10-11 14:09:56.000000000 +0000
++++ CMakeLists.txt
+@@ -11,7 +11,7 @@ if( UNIX )
+ if( BSD )
+ SET( CMAKE_THREAD_LIBS -pthread )
+ SET( CMAKE_USE_PTHREADS ON )
+- SET( CMAKE_EXE_LINKER_FLAGS -pthread )
++ SET( CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -pthread" )
+ endif( BSD )
+ endif( UNIX )
+
diff --git a/net-im/qutim/files/patch-src_3rdparty_qtsolutions_qtlocalpeer.cpp b/net-im/qutim/files/patch-src_3rdparty_qtsolutions_qtlocalpeer.cpp
new file mode 100644
index 000000000000..2ac84174da40
--- /dev/null
+++ b/net-im/qutim/files/patch-src_3rdparty_qtsolutions_qtlocalpeer.cpp
@@ -0,0 +1,10 @@
+--- src/3rdparty/qtsolutions/qtlocalpeer.cpp.orig 2009-06-03 11:32:52.000000000 +0000
++++ src/3rdparty/qtsolutions/qtlocalpeer.cpp
+@@ -56,6 +56,7 @@ typedef BOOL(WINAPI*PProcessIdToSessionI
+ static PProcessIdToSessionId pProcessIdToSessionId = 0;
+ #endif
+ #if defined(Q_OS_UNIX)
++#include <unistd.h>
+ #include <time.h>
+ #endif
+