aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-06-19 02:08:53 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-06-19 02:08:53 +0800
commit3ff8eb657adff6f5bd99ecc182e2b7577fbad68e (patch)
tree0f8c86dc02ba6f9f18b016a8e71262737f4b5362 /net-im
parentd1304e1e2b0c7e7006e75d0b89a28b58e962d31c (diff)
downloadfreebsd-ports-gnome-3ff8eb657adff6f5bd99ecc182e2b7577fbad68e.tar.gz
freebsd-ports-gnome-3ff8eb657adff6f5bd99ecc182e2b7577fbad68e.tar.zst
freebsd-ports-gnome-3ff8eb657adff6f5bd99ecc182e2b7577fbad68e.zip
- Update to 1.1.12
- Fix DISTFILES: do not hardcode version - Add perl5 CATEGORIES - Use bsd.port.options.mk - Make portlint happier - Cosmetic change Changes: http://www.floodgap.com/software/ttytter/dl.html 1.1.12: - Patches for Perl 5.14 (thanks @rkfb for the report). - Keyfiles can now be regenerated if they are corrupted or need to be updated with -retoke. - /doesfollow should give true or false with -runcommand (thanks @kaleidoscopique for the report). Similarly, /short should also work, emitting the URL (thanks @microlifter for that report). - Properly understands a new Twitter ad-hoc error format, which repairs some operations that would unexpectedly appear to succeed but didn't actually (thanks @augmentedfourth for the report). - -readline autocomplete command list now up-to-date. 1.1.11: - Fixed a bug where TTYtter crashes ungracefully if OAuth credentials fail. - Fixed regex in command processor that interpreted all commands starting with /p as /print. - -notimeline is now properly recognized by /set as a boolean. - One last issue related to URL shortening. PR: ports/157888 Submitted by: sunpoet (myself) Approved by: Julian Dunn <jdunn@aquezada.com> (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/ttytter/Makefile36
-rw-r--r--net-im/ttytter/distinfo4
2 files changed, 20 insertions, 20 deletions
diff --git a/net-im/ttytter/Makefile b/net-im/ttytter/Makefile
index 4c0e99370df3..d9b9385c3514 100644
--- a/net-im/ttytter/Makefile
+++ b/net-im/ttytter/Makefile
@@ -1,48 +1,48 @@
# New ports collection makefile for: ttytter
-# Date created: 21 March 2009
-# Whom: Julian C. Dunn <jdunn@aquezada.com>
+# Date created: 21 March 2009
+# Whom: Julian C. Dunn <jdunn@aquezada.com>
#
# $FreeBSD$
PORTNAME= ttytter
-PORTVERSION= 1.1.10
-CATEGORIES= net-im
+PORTVERSION= 1.1.12
+CATEGORIES= net-im perl5
MASTER_SITES= http://www.floodgap.com/software/ttytter/dist1/
-DISTFILES= 1.1.10.txt
-EXTRACT_ONLY=
+DISTNAME= ${PORTVERSION}
+EXTRACT_SUFX= .txt
MAINTAINER= jdunn@aquezada.com
COMMENT= Command-line Twitter client in Perl
-RUN_DEPENDS= ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- curl:${PORTSDIR}/ftp/curl
+RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
USE_PERL5_RUN= yes
-OPTIONS= READLINE "Include rich readline support" on \
- RLTTYTTER "Use T::R::TTYtter readline driver (beta!)" off \
+OPTIONS= READLINE "Include rich readline support" on \
+ RLTTYTTER "Use T::R::TTYtter readline driver (beta!)" off \
PLIST_FILES= bin/${PORTNAME}
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_READLINE)
-RUN_DEPENDS+= ${SITE_PERL}/Term/ReadLine/Perl.pm:${PORTSDIR}/devel/p5-ReadLine-Perl
+.if !defined(WITHOUT_READLINE)
+RUN_DEPENDS+= p5-ReadLine-Perl>=0:${PORTSDIR}/devel/p5-ReadLine-Perl
.endif
.if defined(WITH_RLTTYTTER)
-RUN_DEPENDS+= ${SITE_PERL}/Term/ReadLine/TTYtter.pm:${PORTSDIR}/devel/p5-ReadLine-TTYtter
+RUN_DEPENDS+= p5-ReadLine-TTYtter>=0:${PORTSDIR}/devel/p5-ReadLine-TTYtter
.endif
do-extract:
@${MKDIR} ${WRKSRC}
- @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.txt
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}/${DISTFILES}
post-patch:
- @${REINPLACE_CMD} -e 's|^\#!/usr/bin/perl|\#!${PERL}|' ${WRKSRC}/${PORTNAME}-${PORTVERSION}.txt
+ @${REINPLACE_CMD} -e 's|^\#!/usr/bin/perl|\#!${PERL}|' ${WRKSRC}/${DISTFILES}
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}-${PORTVERSION}.txt ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTFILES} ${PREFIX}/bin/${PORTNAME}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/ttytter/distinfo b/net-im/ttytter/distinfo
index 93a21507b38e..ce275d840868 100644
--- a/net-im/ttytter/distinfo
+++ b/net-im/ttytter/distinfo
@@ -1,2 +1,2 @@
-SHA256 (1.1.10.txt) = 5d78c562ebc57a4f8c1467e5c169281ebf8096c8f966c11843fde6bb429c111e
-SIZE (1.1.10.txt) = 150600
+SHA256 (1.1.12.txt) = 9df043ceae85bab57da34fb02542b9eb70c90f0c8f65db90192f80e8f9cf0f13
+SIZE (1.1.12.txt) = 157104