aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-12-15 23:59:14 +0800
committerwg <wg@FreeBSD.org>2013-12-15 23:59:14 +0800
commitb425dd4839bf6cd427cfbc5385f9ea4d6b857d95 (patch)
tree2cf7039e1f0f6ce418c713fbe7f5095e80002114 /net-im
parent3d5ecdc10a948fba67d7a77f5ea85abbe44f4c65 (diff)
downloadfreebsd-ports-gnome-b425dd4839bf6cd427cfbc5385f9ea4d6b857d95.tar.gz
freebsd-ports-gnome-b425dd4839bf6cd427cfbc5385f9ea4d6b857d95.tar.zst
freebsd-ports-gnome-b425dd4839bf6cd427cfbc5385f9ea4d6b857d95.zip
net-im/cjc: fix python usage and minor fixes
- Fix python usage to remove implicit dependency on lang/python - Restrict to python 2.x - Remove uselesss LICENSE_FILE - Use new options for docs Reported by: exp-run (PR 184591)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/cjc/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/net-im/cjc/Makefile b/net-im/cjc/Makefile
index c3f06853824d..9370ab3a16bb 100644
--- a/net-im/cjc/Makefile
+++ b/net-im/cjc/Makefile
@@ -10,11 +10,10 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The Console Jabber Client
LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyxmpp>=1.1.0:${PORTSDIR}/net-im/py-pyxmpp
-USE_PYTHON= 2.6+
+USE_PYTHON= 2
NO_STAGE= yes
post-patch:
@@ -25,10 +24,13 @@ post-patch:
/pkg_docdir/s|^|#|g ; \
s|INSTALL=.*|INSTALL=${INSTALL}| ; \
s|INSTALL_DATA=.*|INSTALL_DATA=${INSTALL_DATA}| ; \
- s|INSTALL_DIR=.*|INSTALL_DIR=${MKDIR}|g" ${WRKSRC}/Makefile
+ s|INSTALL_DIR=.*|INSTALL_DIR=${MKDIR}|g ; \
+ s|python |${PYTHON_CMD} |g" ${WRKSRC}/Makefile
+
+.include <bsd.port.options.mk>
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/manual.html ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}