aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2016-03-19 18:59:47 +0800
committerdinoex <dinoex@FreeBSD.org>2016-03-19 18:59:47 +0800
commit84c64949d0a5cd1f678915eb9813be5cdd8ee7ad (patch)
treec39511930fc06a2d7a90f13b5c488344f740ef39 /net-im
parent3aaa365111fcad9f9d10f9a159f51ed88ba01629 (diff)
downloadfreebsd-ports-gnome-84c64949d0a5cd1f678915eb9813be5cdd8ee7ad.tar.gz
freebsd-ports-gnome-84c64949d0a5cd1f678915eb9813be5cdd8ee7ad.tar.zst
freebsd-ports-gnome-84c64949d0a5cd1f678915eb9813be5cdd8ee7ad.zip
- remove option to disable OpenSSL
- add option for gpgme support - cleanup option NLS PR: 207713
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index 287dd8967324..90e9a6dca9dc 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -3,7 +3,7 @@
PORTNAME= base
PORTVERSION= ${LICQ_VER}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-im
PKGNAMESUFFIX= ${SOCKS_SUFFIX}${PKGNAMESUFFIX2}
@@ -15,29 +15,28 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
USES= cmake iconv
+USE_OPENSSL= yes
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
CFLAGS+= -I${LOCALBASE}/include
CXXFLAGS+= -DGTEST_USE_OWN_TR1_TUPLE
-OPTIONS_DEFINE= NLS OPENSSL
-OPTIONS_DEFAULT=OPENSSL
+OPTIONS_DEFINE= NLS GPGME
+OPTIONS_DEFAULT=NLS GPGME
+OPTIONS_SUB=yes
+GPGME_DESC= Build support for gpgme
+NLS_USES= gettext
+NLS_CMAKE_OFF= -DENABLE_NLS:BOOL=OFF
-OPENSSL_USE= OPENSSL=yes
+GPGME_LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
+ libassuan.so:${PORTSDIR}/security/libassuan \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
.include <bsd.port.options.mk>
.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-CMAKE_ARGS+= -DENABLE_NLS:BOOL=OFF
-PLIST_SUB+= NLS="@comment "
-.endif
-
pre-configure:
${REINPLACE_CMD} -e 's=!/bin/bash=!${LOCALBASE}/bin/bash=' \
${WRKSRC}/bin/sidclean.sh