aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-10-08 02:28:27 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-10-08 02:28:27 +0800
commitb50072b6d340fc509e448225b1364265534ad6fb (patch)
treeecf5ede6b449f7f677dfd53086ba339c6eed7396 /net-im
parentefd1605e9fc952a58ba764965b7347d745d18620 (diff)
downloadfreebsd-ports-gnome-b50072b6d340fc509e448225b1364265534ad6fb.tar.gz
freebsd-ports-gnome-b50072b6d340fc509e448225b1364265534ad6fb.tar.zst
freebsd-ports-gnome-b50072b6d340fc509e448225b1364265534ad6fb.zip
- Add runtime dependency on net-im/tox (workaround).
- Remove stale libXft dependency. Add instead: * Fontconfig / freetype2 dependencies. * USE_XORG = x11 xext xrender. - Add missing dependencies (libv4l / libvpx / openal). - Make dbus dependency optional. PR: 194136 Submitted by: s3erios@gmail.com Approved by: fidaj@ukr.net (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/uTox/Makefile17
1 files changed, 14 insertions, 3 deletions
diff --git a/net-im/uTox/Makefile b/net-im/uTox/Makefile
index 41bc6300d5fa..a86b2c3f8f2f 100644
--- a/net-im/uTox/Makefile
+++ b/net-im/uTox/Makefile
@@ -2,6 +2,7 @@
PORTNAME= uTox
DISTVERSION= 0.1.8.git20140925
+PORTREVISION= 1
CATEGORIES= net-im net-p2p
MAINTAINER= fidaj@ukr.net
@@ -12,8 +13,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox \
${LOCALBASE}/include/linux/videodev2.h:${PORTSDIR}/multimedia/v4l_compat
-LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus \
- libXft.so:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
+ libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
+ libv4lconvert.so:${PORTSDIR}/multimedia/libv4l \
+ libvpx.so:${PORTSDIR}/multimedia/libvpx
+RUN_DEPENDS= ${LOCALBASE}/lib/libtoxcore.a:${PORTSDIR}/net-im/tox
USE_GITHUB= yes
GH_ACCOUNT= notsecure
@@ -21,9 +25,16 @@ GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${GH_COMMIT}
GH_COMMIT= 3f86bb5
-USES= compiler:c11 desktop-file-utils gmake pkgconfig
+USES= compiler:c11 desktop-file-utils gmake openal:al pkgconfig
+USE_XORG= x11 xext xrender
INSTALLS_ICONS= yes
+OPTIONS_DEFINE= DBUS
+OPTIONS_DEFAULT= DBUS
+
+DBUS_LIB_DEPENDS= libdbus-1.so:${PORTSDIR}/devel/dbus
+DBUS_MAKE_ARGS_OFF= DBUS=0
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/utox