aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoravilla <avilla@FreeBSD.org>2013-05-03 05:28:26 +0800
committeravilla <avilla@FreeBSD.org>2013-05-03 05:28:26 +0800
commitb5bacb638545565d64832110122fed6b73bae244 (patch)
tree7afec1854175cefafc569e3518ecdd3e4a20e4f2 /net-im
parent82b5927c4e70a27f6df19802540ef0c078e663ec (diff)
downloadfreebsd-ports-gnome-b5bacb638545565d64832110122fed6b73bae244.tar.gz
freebsd-ports-gnome-b5bacb638545565d64832110122fed6b73bae244.tar.zst
freebsd-ports-gnome-b5bacb638545565d64832110122fed6b73bae244.zip
Qt wrapper around the Telepathy Logger client library.
Telepathy is a D-Bus framework for unifying real time communication, including instant messaging, voice calls and video calls. It abstracts differences between protocols to provide a unified interface for applications. WWW: http://community.kde.org/KTp
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/telepathy-logger-qt4/Makefile41
-rw-r--r--net-im/telepathy-logger-qt4/distinfo2
-rw-r--r--net-im/telepathy-logger-qt4/pkg-descr8
-rw-r--r--net-im/telepathy-logger-qt4/pkg-plist44
5 files changed, 96 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 9d6025ca136d..27d8b4507f1d 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -162,6 +162,7 @@
SUBDIR += telepathy-haze
SUBDIR += telepathy-idle
SUBDIR += telepathy-logger
+ SUBDIR += telepathy-logger-qt4
SUBDIR += telepathy-mission-control
SUBDIR += telepathy-python
SUBDIR += telepathy-qt
diff --git a/net-im/telepathy-logger-qt4/Makefile b/net-im/telepathy-logger-qt4/Makefile
new file mode 100644
index 000000000000..7dd9b07929b2
--- /dev/null
+++ b/net-im/telepathy-logger-qt4/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= telepathy-logger-qt4
+PORTVERSION= 0.6.0
+CATEGORIES= net-im
+MASTER_SITES= ${MASTER_SITE_KDE}
+MASTER_SITE_SUBDIR= stable/kde-telepathy/${PORTVERSION}/src
+DISTNAME= ${PORTNAME:C/4$//}-${PORTVERSION}
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= Qt binding for Telepathy Logger
+
+LICENSE= LGPL21
+
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus \
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
+ telepathy-logger:${PORTSDIR}/net-im/telepathy-logger \
+ telepathy-qt4:${PORTSDIR}/net-im/telepathy-qt4
+
+USE_GNOME= glib20 libxml2
+USE_GSTREAMER= qt4
+USE_KDE4= # empty
+USE_PYTHON_BUILD= 2.5+
+USE_QT4= corelib dbus moc_build qmake_build rcc_build uic_build
+USES= bison:build cmake
+USE_BZIP2= yes
+CMAKE_ARGS= -DUSE_COMMON_CMAKE_PACKAGE_CONFIG_DIR:BOOL=True
+MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e '/FIND_PROGRAM/ s,qmake ,,' \
+ ${WRKSRC}/cmake/modules/FindQt.cmake
+ @${REINPLACE_CMD} -e '/$${QTGLIB_INCLUDE_DIR}/ s,)$$, ${LOCALBASE}/include),' \
+ ${WRKSRC}/CMakeLists.txt
+ @${REINPLACE_CMD} -e '/$${GOBJECT_LIBRARIES}/ s,$$, -L${LOCALBASE}/lib,' \
+ -e 's,$${LIB_INSTALL_DIR}/pkgconfig,libdata/pkgconfig,' \
+ ${WRKSRC}/TelepathyLoggerQt4/CMakeLists.txt
+
+.include <bsd.port.mk>
diff --git a/net-im/telepathy-logger-qt4/distinfo b/net-im/telepathy-logger-qt4/distinfo
new file mode 100644
index 000000000000..65c535983600
--- /dev/null
+++ b/net-im/telepathy-logger-qt4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (telepathy-logger-qt-0.6.0.tar.bz2) = 3dee0e49725ee0f40bc137322c2dd2a9499de0506d056091f80d0ee416f3b104
+SIZE (telepathy-logger-qt-0.6.0.tar.bz2) = 105254
diff --git a/net-im/telepathy-logger-qt4/pkg-descr b/net-im/telepathy-logger-qt4/pkg-descr
new file mode 100644
index 000000000000..aaa3e9d5babd
--- /dev/null
+++ b/net-im/telepathy-logger-qt4/pkg-descr
@@ -0,0 +1,8 @@
+Qt wrapper around the Telepathy Logger client library.
+
+Telepathy is a D-Bus framework for unifying real time communication,
+including instant messaging, voice calls and video calls. It abstracts
+differences between protocols to provide a unified interface for
+applications.
+
+WWW: http://community.kde.org/KTp
diff --git a/net-im/telepathy-logger-qt4/pkg-plist b/net-im/telepathy-logger-qt4/pkg-plist
new file mode 100644
index 000000000000..68d428f31417
--- /dev/null
+++ b/net-im/telepathy-logger-qt4/pkg-plist
@@ -0,0 +1,44 @@
+include/telepathy-logger-0.2/TelepathyLoggerQt4/CallEvent
+include/telepathy-logger-0.2/TelepathyLoggerQt4/Entity
+include/telepathy-logger-0.2/TelepathyLoggerQt4/Event
+include/telepathy-logger-0.2/TelepathyLoggerQt4/Global
+include/telepathy-logger-0.2/TelepathyLoggerQt4/Init
+include/telepathy-logger-0.2/TelepathyLoggerQt4/LogManager
+include/telepathy-logger-0.2/TelepathyLoggerQt4/PendingDates
+include/telepathy-logger-0.2/TelepathyLoggerQt4/PendingEntities
+include/telepathy-logger-0.2/TelepathyLoggerQt4/PendingEvents
+include/telepathy-logger-0.2/TelepathyLoggerQt4/PendingOperation
+include/telepathy-logger-0.2/TelepathyLoggerQt4/PendingSearch
+include/telepathy-logger-0.2/TelepathyLoggerQt4/SearchHit
+include/telepathy-logger-0.2/TelepathyLoggerQt4/TextEvent
+include/telepathy-logger-0.2/TelepathyLoggerQt4/Types
+include/telepathy-logger-0.2/TelepathyLoggerQt4/_gen/cli-logger.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/_gen/constants.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/_gen/types.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/call-event.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/entity.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/event.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/global.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/init.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/log-manager.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/pending-dates.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/pending-entities.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/pending-events.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/pending-operation.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/pending-search.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/search-hit.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/text-event.h
+include/telepathy-logger-0.2/TelepathyLoggerQt4/types.h
+lib/cmake/TelepathyLoggerQt4/TelepathyLoggerQt4Config.cmake
+lib/cmake/TelepathyLoggerQt4/TelepathyLoggerQt4ConfigVersion.cmake
+lib/cmake/TelepathyLoggerQt4/TelepathyLoggerQt4Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/TelepathyLoggerQt4/TelepathyLoggerQt4Targets.cmake
+lib/libtelepathy-logger-qt4.so
+lib/libtelepathy-logger-qt4.so.1
+lib/libtelepathy-logger-qt4.so.1.0.5.60
+libdata/pkgconfig/TelepathyLoggerQt4.pc
+@dirrm lib/cmake/TelepathyLoggerQt4
+@dirrmtry lib/cmake
+@dirrm include/telepathy-logger-0.2/TelepathyLoggerQt4/_gen
+@dirrm include/telepathy-logger-0.2/TelepathyLoggerQt4
+@dirrmtry include/telepathy-logger-0.2