aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-03-07 23:39:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-03-07 23:39:15 +0800
commit177f1745e85b5ed20524e4e0cf7551fdbf9f783c (patch)
tree89dfcdd9b1b232e41321bc2fd9a365799c6ab888 /net-im
parent53a9bb0610908d26c3b4872b1e9b1a3acb723d8a (diff)
downloadfreebsd-ports-gnome-177f1745e85b5ed20524e4e0cf7551fdbf9f783c.tar.gz
freebsd-ports-gnome-177f1745e85b5ed20524e4e0cf7551fdbf9f783c.tar.zst
freebsd-ports-gnome-177f1745e85b5ed20524e4e0cf7551fdbf9f783c.zip
- Add p5-Net-Async-XMPP 0.002
Net::Async::XMPP is an asynchronous XMPP client and server implementations. WWW: http://search.cpan.org/dist/Net-Async-XMPP/ PR: ports/155342 Submitted by: "ports@c0decafe.net" <ports@c0decafe.net>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/p5-Net-Async-XMPP/Makefile30
-rw-r--r--net-im/p5-Net-Async-XMPP/distinfo2
-rw-r--r--net-im/p5-Net-Async-XMPP/pkg-descr3
-rw-r--r--net-im/p5-Net-Async-XMPP/pkg-plist12
5 files changed, 48 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index e9fc03d566d6..1769517bf116 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -102,6 +102,7 @@
SUBDIR += p5-Jabber-SimpleSend
SUBDIR += p5-Net-AIM
SUBDIR += p5-Net-AOLIM
+ SUBDIR += p5-Net-Async-XMPP
SUBDIR += p5-Net-ICQ2000
SUBDIR += p5-Net-Jabber
SUBDIR += p5-Net-MSN
diff --git a/net-im/p5-Net-Async-XMPP/Makefile b/net-im/p5-Net-Async-XMPP/Makefile
new file mode 100644
index 000000000000..29bb325e3772
--- /dev/null
+++ b/net-im/p5-Net-Async-XMPP/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Net-Async-XMPP
+# Date created: 2011-03-07
+# Whom: <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Async-XMPP
+PORTVERSION= 0.002
+CATEGORIES= net-im perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:TEAM
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Asynchronous XMPP client and server
+
+RUN_DEPENDS= p5-IO-Async>=0.37:${PORTSDIR}/devel/p5-IO-Async \
+ p5-IO-Async-SSL>=0.04:${PORTSDIR}/security/p5-IO-Async-SSL \
+ p5-Protocol-XMPP>=0.002:${PORTSDIR}/net-im/p5-Protocol-XMPP \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::Async::XMPP.3 \
+ Net::Async::XMPP::Client.3 \
+ Net::Async::XMPP::Protocol.3 \
+ Net::Async::XMPP::Server.3
+
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-Async-XMPP/distinfo b/net-im/p5-Net-Async-XMPP/distinfo
new file mode 100644
index 000000000000..d2fde2bb7526
--- /dev/null
+++ b/net-im/p5-Net-Async-XMPP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Net-Async-XMPP-0.002.tar.gz) = ebe00a1d73a20cc7aa3edbcbb3ff8b0597152645349c698f8be6dbb035daeda8
+SIZE (Net-Async-XMPP-0.002.tar.gz) = 11790
diff --git a/net-im/p5-Net-Async-XMPP/pkg-descr b/net-im/p5-Net-Async-XMPP/pkg-descr
new file mode 100644
index 000000000000..488a23479df1
--- /dev/null
+++ b/net-im/p5-Net-Async-XMPP/pkg-descr
@@ -0,0 +1,3 @@
+Net::Async::XMPP is an asynchronous XMPP client and server implementations.
+
+WWW: http://search.cpan.org/dist/Net-Async-XMPP/
diff --git a/net-im/p5-Net-Async-XMPP/pkg-plist b/net-im/p5-Net-Async-XMPP/pkg-plist
new file mode 100644
index 000000000000..ce05dd8302b3
--- /dev/null
+++ b/net-im/p5-Net-Async-XMPP/pkg-plist
@@ -0,0 +1,12 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/Async/XMPP.pm
+%%SITE_PERL%%/Net/Async/XMPP/Client.pm
+%%SITE_PERL%%/Net/Async/XMPP/Protocol.pm
+%%SITE_PERL%%/Net/Async/XMPP/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/XMPP/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async/XMPP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Async
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/Async/XMPP
+@dirrmtry %%SITE_PERL%%/Net/Async
+@dirrmtry %%SITE_PERL%%/Net