aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-07-29 10:08:47 +0800
committerijliao <ijliao@FreeBSD.org>2004-07-29 10:08:47 +0800
commit24fca8096f00d48fe182fe89b6e5d8cc51261a31 (patch)
tree1a0d4a343a238d2417fee24bd3e542b3573bc57e /net-im
parent0d8f300d089d002ff4236161b786eca7f82557ca (diff)
downloadfreebsd-ports-gnome-24fca8096f00d48fe182fe89b6e5d8cc51261a31.tar.gz
freebsd-ports-gnome-24fca8096f00d48fe182fe89b6e5d8cc51261a31.tar.zst
freebsd-ports-gnome-24fca8096f00d48fe182fe89b6e5d8cc51261a31.zip
fix msn 100% cpu loading problem
Obtained from: centericq mailing list Approved by: maintainer
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile1
-rw-r--r--net-im/centericq/files/patch-msnhook.cc16
2 files changed, 14 insertions, 3 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index b181de91bd78..e7b920a5cc41 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -8,6 +8,7 @@
PORTNAME= centericq
PORTVERSION= 4.10.0
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://centericq.de/archive/source/releases/
diff --git a/net-im/centericq/files/patch-msnhook.cc b/net-im/centericq/files/patch-msnhook.cc
index 0bbda9b195eb..6f1486372147 100644
--- a/net-im/centericq/files/patch-msnhook.cc
+++ b/net-im/centericq/files/patch-msnhook.cc
@@ -1,6 +1,16 @@
---- src/hooks/msnhook.cc.orig Sun Mar 7 21:44:41 2004
-+++ src/hooks/msnhook.cc Fri Apr 2 10:23:03 2004
-@@ -408,11 +408,11 @@
+--- src/hooks/msnhook.cc.orig Thu Jul 1 03:42:16 2004
++++ src/hooks/msnhook.cc Thu Jul 29 10:02:57 2004
+@@ -155,6 +155,9 @@
+ int hsock = 0;
+ MSN::Connection *c;
+
++ FD_ZERO(&rs);
++ FD_ZERO(&ws);
++ FD_ZERO(&es);
+ getsockets(rs, ws, es, hsock);
+ tv.tv_sec = tv.tv_usec = 0;
+
+@@ -451,11 +454,11 @@
void msnhook::checkfriendly(icqcontact *c, const string friendlynick, bool forcefetch) {
string oldnick = c->getnick();