aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-09-09 12:47:35 +0800
committermarcus <marcus@FreeBSD.org>2002-09-09 12:47:35 +0800
commit49b9775ac84c0d5c1f2aadd56bb5d8b3183e10b8 (patch)
tree1fc41e27abef9143507d148de75215570838eaa8 /net-im
parent6ef05a2c219e843b715d7843e93ab520e2b2302e (diff)
downloadfreebsd-ports-gnome-49b9775ac84c0d5c1f2aadd56bb5d8b3183e10b8.tar.gz
freebsd-ports-gnome-49b9775ac84c0d5c1f2aadd56bb5d8b3183e10b8.tar.zst
freebsd-ports-gnome-49b9775ac84c0d5c1f2aadd56bb5d8b3183e10b8.zip
Fix things after recent GNOMENG commit.
Submitted by: bento
Diffstat (limited to 'net-im')
-rw-r--r--net-im/gicq/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/net-im/gicq/Makefile b/net-im/gicq/Makefile
index c2cb375c46c2..60eeb8113eda 100644
--- a/net-im/gicq/Makefile
+++ b/net-im/gicq/Makefile
@@ -19,26 +19,25 @@ LIB_DEPENDS= icq.0:${PORTSDIR}/net/libicq
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_GNOMENG= yes
+USE_GNOME= gtk12
WANT_GNOME= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mgtk12}!=""
-USE_GNOME+= gtk12
-PKGNAMESUFFIX= -gtk
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+USE_GNOME+= gnomeprefix gnomehack gnomelibs
+PKGNAMESUFFIX= -gnome
.else
CONFIGURE_ARGS+=--without-gnome
.endif
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
- s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g'
.include <bsd.port.post.mk>