aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2009-12-10 21:04:35 +0800
committerwen <wen@FreeBSD.org>2009-12-10 21:04:35 +0800
commit4c462d9139719a0982a494c5d40927dc53b8b4e3 (patch)
treed4c9da2ce091fed781384b834a9a1f9a34157f37 /net-im
parentd66884f3b7ae2907e7232f9ff43c630e5cf25f71 (diff)
downloadfreebsd-ports-gnome-4c462d9139719a0982a494c5d40927dc53b8b4e3.tar.gz
freebsd-ports-gnome-4c462d9139719a0982a494c5d40927dc53b8b4e3.tar.zst
freebsd-ports-gnome-4c462d9139719a0982a494c5d40927dc53b8b4e3.zip
- Fix the run error with python-2.6 [1]
- Add the missing run dependence PR: ports/141338 [1] Submitted by: kevin <kevinxlinuz@163.com> [1]
Diffstat (limited to 'net-im')
-rw-r--r--net-im/py-xmpppy/Makefile3
-rw-r--r--net-im/py-xmpppy/files/patch-xmpp-auth.py14
2 files changed, 17 insertions, 0 deletions
diff --git a/net-im/py-xmpppy/Makefile b/net-im/py-xmpppy/Makefile
index 816f8ac44245..f3712ad483e2 100644
--- a/net-im/py-xmpppy/Makefile
+++ b/net-im/py-xmpppy/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xmpppy
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= net-im python
MASTER_SITES= SF
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,6 +15,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= wenheping@gmail.com
COMMENT= A Python library that provides easy scripting with Jabber
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dnspython>=1.7.1:${PORTSDIR}/dns/py-dnspython
+
USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
diff --git a/net-im/py-xmpppy/files/patch-xmpp-auth.py b/net-im/py-xmpppy/files/patch-xmpp-auth.py
new file mode 100644
index 000000000000..db7c46813ff1
--- /dev/null
+++ b/net-im/py-xmpppy/files/patch-xmpp-auth.py
@@ -0,0 +1,14 @@
+--- xmpp/auth.py.orig 2009-12-10 20:43:19.000000000 +0800
++++ xmpp/auth.py 2009-12-10 20:44:17.000000000 +0800
+@@ -21,9 +21,9 @@
+
+ from protocol import *
+ from client import PlugIn
+-import sha,base64,random,dispatcher,re
++import base64,random,dispatcher,re
+
+-import md5
++import hashlib
+ def HH(some): return md5.new(some).hexdigest()
+ def H(some): return md5.new(some).digest()
+ def C(some): return ':'.join(some)