aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2005-10-04 10:42:24 +0800
committerclsung <clsung@FreeBSD.org>2005-10-04 10:42:24 +0800
commit6749634061cb5c7de8ea0ad0fcc2c54d4f648ffd (patch)
tree6e758cf78f37fabdd11ab3fcf7b60a59425e30ac /net-im
parent06c276b807a135c8f3ba0a79b4bab149014e6f79 (diff)
downloadfreebsd-ports-gnome-6749634061cb5c7de8ea0ad0fcc2c54d4f648ffd.tar.gz
freebsd-ports-gnome-6749634061cb5c7de8ea0ad0fcc2c54d4f648ffd.tar.zst
freebsd-ports-gnome-6749634061cb5c7de8ea0ad0fcc2c54d4f648ffd.zip
- Add an option and appropriate LIB_DEPENDS to enable/disable PGP
encryption of Jabber messages. PR: 86670 Submitted by: Stefan Walter <sw AT gegenunendlich dot de>
Diffstat (limited to 'net-im')
-rw-r--r--net-im/centericq/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-im/centericq/Makefile b/net-im/centericq/Makefile
index cf9292455416..b2813d818b36 100644
--- a/net-im/centericq/Makefile
+++ b/net-im/centericq/Makefile
@@ -34,6 +34,7 @@ OPTIONS= NLS "Native Language Support" on \
AIM "Support for AOL's Instant Messenger Protocol" off \
IRC "Support for IRC Protocol" off \
JABBER "Support for Jabber Protocol" off \
+ GPGME "Support for PGP encrypted Jabber messages" on \
RSS "Support for RSS" off \
LJ "Support for LiveJournal" off \
GG "Support for Gadu-Gadu Protocol" off
@@ -81,6 +82,13 @@ CONFIGURE_ARGS+= --disable-irc
.if !defined(WITH_JABBER)
CONFIGURE_ARGS+= --disable-jabber
+.else
+.if !defined(WITH_GPGME)
+CONFIGURE_ARGS+= --without-gpgme
+.else
+LIB_DEPENDS+= gpgme.14:${PORTSDIR}/security/gpgme
+CONFIGURE_ARGS+= --with-gpgme=${LOCALBASE}
+.endif
.endif
.if !defined(WITH_RSS)