aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-06-29 04:57:11 +0800
committermarcus <marcus@FreeBSD.org>2004-06-29 04:57:11 +0800
commit98c20eaba7f3b2db8c0f2b64da2546811f681105 (patch)
tree0748c023858f56d0d16185e1c0ecb41ce65c7114 /net-im
parentd52da2eb9001398579395df0ec72d18694e7111d (diff)
downloadfreebsd-ports-gnome-98c20eaba7f3b2db8c0f2b64da2546811f681105.tar.gz
freebsd-ports-gnome-98c20eaba7f3b2db8c0f2b64da2546811f681105.tar.zst
freebsd-ports-gnome-98c20eaba7f3b2db8c0f2b64da2546811f681105.zip
Properly convert ';' to ' ' in the user names.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/meanwhile/Makefile1
-rw-r--r--net-im/meanwhile/files/patch-st_list.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/net-im/meanwhile/Makefile b/net-im/meanwhile/Makefile
index 49a4ae9f9863..e32fbe411f6c 100644
--- a/net-im/meanwhile/Makefile
+++ b/net-im/meanwhile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= meanwhile
PORTVERSION= 0.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net-im/meanwhile/files/patch-st_list.c b/net-im/meanwhile/files/patch-st_list.c
new file mode 100644
index 000000000000..c00376f750fc
--- /dev/null
+++ b/net-im/meanwhile/files/patch-st_list.c
@@ -0,0 +1,10 @@
+--- src/st_list.c.orig Mon Jun 28 16:56:44 2004
++++ src/st_list.c Mon Jun 28 16:56:56 2004
+@@ -387,6 +387,7 @@
+ b = tmp;
+
+ name = b + 4; /* advance past the "1:: " */
++ str_replace(name, ';', ' ');
+ tmp = strchr(name, ',');
+ if(tmp) {
+ *tmp = '\0';