aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-05-20 17:14:02 +0800
committergahr <gahr@FreeBSD.org>2014-05-20 17:14:02 +0800
commit9d6bce6fabe7dbdc6b71d6e0046ffe00976e9b3c (patch)
tree28c8168ae8a3b54ddebc134ba0eb138aaeba7a9b /net-im
parentc159662c41bc03ac490e1c0995cef2e0b3765ee1 (diff)
downloadfreebsd-ports-gnome-9d6bce6fabe7dbdc6b71d6e0046ffe00976e9b3c.tar.gz
freebsd-ports-gnome-9d6bce6fabe7dbdc6b71d6e0046ffe00976e9b3c.tar.zst
freebsd-ports-gnome-9d6bce6fabe7dbdc6b71d6e0046ffe00976e9b3c.zip
- Update to 3.9.3
Release notes: https://community.igniterealtime.org/blogs/ignite/2014/05/06/openfire-393-has-been-released
Diffstat (limited to 'net-im')
-rw-r--r--net-im/openfire/Makefile17
-rw-r--r--net-im/openfire/distinfo4
-rw-r--r--net-im/openfire/files/pkg-message.in1
-rw-r--r--net-im/openfire/pkg-plist17
4 files changed, 22 insertions, 17 deletions
diff --git a/net-im/openfire/Makefile b/net-im/openfire/Makefile
index 92af45eda6db..94021562565e 100644
--- a/net-im/openfire/Makefile
+++ b/net-im/openfire/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openfire
-PORTVERSION= 3.9.1
+PORTVERSION= 3.9.3
PORTEPOCH= 1
CATEGORIES= net-im java
MASTER_SITES= http://download.igniterealtime.org/openfire/
@@ -25,9 +25,7 @@ DOS2UNIX_FILES= src/java/org/jivesoftware/openfire/server/ServerDialback.java
USE_LDCONFIG= yes
USE_ANT= yes
USE_JAVA= yes
-JAVA_VERSION= 1.6+
-
-CONFLICTS= wildfire-[0-9]*
+JAVA_VERSION= 1.6 1.7
ALL_TARGET= openfire
USE_RC_SUBR= openfire
@@ -61,9 +59,9 @@ post-patch:
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}/lib
- @${MKDIR} ${STAGEDIR}${VARLOG}
- @${MKDIR} ${STAGEDIR}${VARDB}
@${MKDIR} ${STAGEDIR}${ETCDIR}
+ @${MKDIR} ${STAGEDIR}${VARDB}
+ @${MKDIR} ${STAGEDIR}${VARLOG}
(cd ${INSTALL_WRKSRC}/lib && ${INSTALL} -m 744 *.jar ${STAGEDIR}${DATADIR}/lib)
(cd ${INSTALL_WRKSRC}/lib && ${INSTALL} -m 744 log4j.xml ${STAGEDIR}${DATADIR}/lib)
@@ -88,16 +86,17 @@ do-install:
(cd ${WRKSRC}/documentation/docs && ${FIND} . \! -path ./javadoc\* \
| ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${STAGEDIR}${DOCSDIR} > /dev/null 2>&1 )
.endif
- ${LN} -sf ${VARLOG} ${STAGEDIR}${DATADIR}/logs
- ${LN} -sf ${VARDB} ${STAGEDIR}${DATADIR}/embedded-db
${LN} -sf ${ETCDIR} ${STAGEDIR}${DATADIR}/conf
${LN} -sf ${ETCDIR} ${STAGEDIR}${DATADIR}/resources/security
-
+ ${LN} -sf ${VARDB} ${STAGEDIR}${DATADIR}/embedded-db
+ ${LN} -sf ${VARLOG} ${STAGEDIR}${DATADIR}/logs
${INSTALL_DATA} ${INSTALL_WRKSRC}/conf/openfire.xml \
${STAGEDIR}${ETCDIR}/openfire.xml.sample
${INSTALL} -m 600 ${INSTALL_WRKSRC}/resources/security/truststore \
${STAGEDIR}${ETCDIR}/truststore.sample
${INSTALL} -m 600 ${INSTALL_WRKSRC}/resources/security/keystore \
${STAGEDIR}${ETCDIR}/keystore.sample
+ ${INSTALL_DATA} ${INSTALL_WRKSRC}/conf/security.xml \
+ ${STAGEDIR}${ETCDIR}/security.xml.sample
.include <bsd.port.mk>
diff --git a/net-im/openfire/distinfo b/net-im/openfire/distinfo
index a63965ab4f57..0ef151ba1fc6 100644
--- a/net-im/openfire/distinfo
+++ b/net-im/openfire/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openfire_src_3_9_1.zip) = aa027461b1b895551ffcaadd4da03797847ac8c809955af8108ec677abbefaa1
-SIZE (openfire_src_3_9_1.zip) = 126568710
+SHA256 (openfire_src_3_9_3.zip) = ae111674abd3888700f7b6abe61b8a1a9d173faac6bc334f0c4686f9b319b8a0
+SIZE (openfire_src_3_9_3.zip) = 84477282
diff --git a/net-im/openfire/files/pkg-message.in b/net-im/openfire/files/pkg-message.in
index f9c3519f8832..b186589f24a1 100644
--- a/net-im/openfire/files/pkg-message.in
+++ b/net-im/openfire/files/pkg-message.in
@@ -5,5 +5,6 @@ The following sample configuration files have been
placed in %%ETCDIR%%:
openfire.xml.sample
+security.xml.sample
keystore.sample
truststore.sample
diff --git a/net-im/openfire/pkg-plist b/net-im/openfire/pkg-plist
index 90fdd44fa2a1..2f88117600e1 100644
--- a/net-im/openfire/pkg-plist
+++ b/net-im/openfire/pkg-plist
@@ -1,8 +1,14 @@
@owner openfire
@group openfire
-%%ETCDIR%%/openfire.xml.sample
-%%ETCDIR%%/keystore.sample
-%%ETCDIR%%/truststore.sample
+@mode 0600
+@sample %%ETCDIR%%/openfire.xml.sample
+@sample %%ETCDIR%%/security.xml.sample
+@sample %%ETCDIR%%/keystore.sample
+@sample %%ETCDIR%%/truststore.sample
+@mode
+%%DATADIR%%/conf
+%%DATADIR%%/embedded-db
+%%DATADIR%%/logs
%%DATADIR%%/lib/activation.jar
%%DATADIR%%/lib/bcpg-jdk15on.jar
%%DATADIR%%/lib/bcpkix-jdk15on.jar
@@ -21,9 +27,6 @@
%%DATADIR%%/lib/servlet.jar
%%DATADIR%%/lib/slf4j-log4j12.jar
%%DATADIR%%/lib/startup.jar
-%%DATADIR%%/conf
-%%DATADIR%%/embedded-db
-%%DATADIR%%/logs
%%DATADIR%%/plugins/admin/plugin.xml
%%DATADIR%%/plugins/admin/webapp/WEB-INF/admin.tld
%%DATADIR%%/plugins/admin/webapp/WEB-INF/decorators.xml
@@ -184,6 +187,8 @@
%%DATADIR%%/plugins/admin/webapp/style/lightbox.css
%%DATADIR%%/plugins/admin/webapp/style/login.css
%%DATADIR%%/plugins/admin/webapp/style/setup.css
+%%DATADIR%%/plugins/jitsivideobridge.jar
+%%DATADIR%%/plugins/rayo.jar
%%PLUGINS%%%%DATADIR%%/plugins/fastpath.jar
%%PLUGINS%%%%DATADIR%%/plugins/broadcast.jar
%%PLUGINS%%%%DATADIR%%/plugins/clientControl.jar