aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-02-12 03:28:01 +0800
committerskv <skv@FreeBSD.org>2007-02-12 03:28:01 +0800
commitbececa08088425120fc7ebdb2723adef18d94e57 (patch)
tree07491b19201d1d2619bf4c5abbab1b84362449d6 /net-im
parent75eae57d50cf1e726406ca7d78baaec683e51161 (diff)
downloadfreebsd-ports-gnome-bececa08088425120fc7ebdb2723adef18d94e57.tar.gz
freebsd-ports-gnome-bececa08088425120fc7ebdb2723adef18d94e57.tar.zst
freebsd-ports-gnome-bececa08088425120fc7ebdb2723adef18d94e57.zip
Add p5-Net-Stomp 0.32, Streaming Text Orientated Messaging Protocol
Client.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/p5-Net-Stomp/Makefile25
-rw-r--r--net-im/p5-Net-Stomp/distinfo3
-rw-r--r--net-im/p5-Net-Stomp/pkg-descr14
-rw-r--r--net-im/p5-Net-Stomp/pkg-plist4
5 files changed, 47 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 140d81098562..11ea0397d7b5 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -105,6 +105,7 @@
SUBDIR += p5-Net-MSN
SUBDIR += p5-Net-NetSend
SUBDIR += p5-Net-OSCAR
+ SUBDIR += p5-Net-Stomp
SUBDIR += p5-Net-XMPP
SUBDIR += psi
SUBDIR += psi-gentoo
diff --git a/net-im/p5-Net-Stomp/Makefile b/net-im/p5-Net-Stomp/Makefile
new file mode 100644
index 000000000000..6ea39b0a7e6f
--- /dev/null
+++ b/net-im/p5-Net-Stomp/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: Net-Stomp
+# Date created: 08 February 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Stomp
+PORTVERSION= 0.32
+CATEGORIES= net-im perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Streaming Text Orientated Messaging Protocol Client
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Net::Stomp.3 Net::Stomp::Frame.3
+
+.include <bsd.port.mk>
diff --git a/net-im/p5-Net-Stomp/distinfo b/net-im/p5-Net-Stomp/distinfo
new file mode 100644
index 000000000000..8df2a197bae4
--- /dev/null
+++ b/net-im/p5-Net-Stomp/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Stomp-0.32.tar.gz) = e18c0639b660c1a07acfafce5e0caff9
+SHA256 (Net-Stomp-0.32.tar.gz) = d83d8001b60223deeaf316dab30a9c7c265cdcb174a34dfc221169a017135545
+SIZE (Net-Stomp-0.32.tar.gz) = 5691
diff --git a/net-im/p5-Net-Stomp/pkg-descr b/net-im/p5-Net-Stomp/pkg-descr
new file mode 100644
index 000000000000..1710f8189e64
--- /dev/null
+++ b/net-im/p5-Net-Stomp/pkg-descr
@@ -0,0 +1,14 @@
+This module allows you to write a Stomp client. Stomp is the Streaming
+Text Orientated Messaging Protocol (or the Protocol Briefly Known as
+TTMP and Represented by the symbol :ttmp). It's a simple and easy to
+implement protocol for working with Message Orientated Middleware from
+any language. Net::Stomp is useful for talking to Apache ActiveMQ, an
+open source (Apache 2.0 licensed) Java Message Service 1.1 (JMS) message
+broker packed with many enterprise features.
+
+A Stomp frame consists of a command, a series of headers and a body -
+see Net::Stomp::Frame for more details.
+
+For details on the protocol see http://stomp.codehaus.org/Protocol.
+
+WWW: http://search.cpan.org/dist/Net-Stomp/
diff --git a/net-im/p5-Net-Stomp/pkg-plist b/net-im/p5-Net-Stomp/pkg-plist
new file mode 100644
index 000000000000..021417a791d1
--- /dev/null
+++ b/net-im/p5-Net-Stomp/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Net/Stomp.pm
+%%SITE_PERL%%/Net/Stomp/Frame.pm
+@dirrm %%SITE_PERL%%/Net/Stomp
+@dirrmtry %%SITE_PERL%%/Net