aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-03-12 11:35:09 +0800
committerijliao <ijliao@FreeBSD.org>2004-03-12 11:35:09 +0800
commitc4adf46f30d267bb4969aec8b6ef46fe88ab54f5 (patch)
treef3716f873528019a6d660f7dac6a04bb08614553 /net-im
parent74e222ca93a52e0ef329e08c114172c16224cc41 (diff)
downloadfreebsd-ports-gnome-c4adf46f30d267bb4969aec8b6ef46fe88ab54f5.tar.gz
freebsd-ports-gnome-c4adf46f30d267bb4969aec8b6ef46fe88ab54f5.tar.zst
freebsd-ports-gnome-c4adf46f30d267bb4969aec8b6ef46fe88ab54f5.zip
add newsbot 0.4.5
Gathers news from RDF/RSS and send them to your IM client
Diffstat (limited to 'net-im')
-rw-r--r--net-im/newsbot/Makefile35
-rw-r--r--net-im/newsbot/distinfo2
-rw-r--r--net-im/newsbot/files/newsbot3
-rw-r--r--net-im/newsbot/pkg-descr17
4 files changed, 57 insertions, 0 deletions
diff --git a/net-im/newsbot/Makefile b/net-im/newsbot/Makefile
new file mode 100644
index 000000000000..3349d02f8bde
--- /dev/null
+++ b/net-im/newsbot/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: newsbot
+# Date created: Mar 12, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= newsbot
+PORTVERSION= 0.4.5
+CATEGORIES= net
+MASTER_SITES= http://www.jabberstudio.org/files/${PORTNAME}/
+DISTNAME= ${PORTNAME}-0.45
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Gathers news from RDF/RSS and send them to your IM client
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/jabber.py:${PORTSDIR}/net/py-jabber
+
+USE_PYTHON= 2.2+
+NO_BUILD= yes
+
+PLIST_FILES= bin/newsbot
+
+do-install:
+ @${SED} "s,%%DATADIR%%,${DATADIR}," \
+ < ${FILESDIR}/newsbot > ${PREFIX}/bin/newsbot
+ @${CHMOD} +x ${PREFIX}/bin/newsbot
+ @${MKDIR} ${DATADIR}
+ @(cd ${WRKSRC} && ${INSTALL_DATA} *.py *.cfg README bothelp ${DATADIR})
+ @${FIND} ${DATADIR} -type f | \
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
+ @${ECHO_CMD} "@dirrm ${DATADIR:S,^${PREFIX}/,,}" >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/net-im/newsbot/distinfo b/net-im/newsbot/distinfo
new file mode 100644
index 000000000000..2e67440fc9a4
--- /dev/null
+++ b/net-im/newsbot/distinfo
@@ -0,0 +1,2 @@
+MD5 (newsbot-0.45.tar.gz) = 83935032e3934f77acf4389304ac84b1
+SIZE (newsbot-0.45.tar.gz) = 32039
diff --git a/net-im/newsbot/files/newsbot b/net-im/newsbot/files/newsbot
new file mode 100644
index 000000000000..88b1421c0c0f
--- /dev/null
+++ b/net-im/newsbot/files/newsbot
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+cd %%DATADIR%%/newsbot && python bot.py
diff --git a/net-im/newsbot/pkg-descr b/net-im/newsbot/pkg-descr
new file mode 100644
index 000000000000..51e56df62372
--- /dev/null
+++ b/net-im/newsbot/pkg-descr
@@ -0,0 +1,17 @@
+newsBot gathers news from various news feeds(RDF/RSS-pages) and send the news
+to your IM client. The bot is a console based application and uses the Jabber
+network for messaging.
+
+Each RDF/RSS-page is checked every 30 min in a running order. When a new news
+item is found, the news will be sent to the users with the website in its site
+list. The news item will include(if available) title, date, link and a short
+description.
+
+Features:
+ * Individual user settings.
+ * 15 bot commands.
+ * Over 30 news feeds to choose from.
+ * Ability to add and remove news feeds.
+ * and more...
+
+WWW: http://newsbot.jabberstudio.org/