aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-02-28 13:11:32 +0800
committermarcus <marcus@FreeBSD.org>2009-02-28 13:11:32 +0800
commitdcb293d5bd3c35bc52899d2ee702bbec08222038 (patch)
treea5c58b59f0ed1328dc4b23c7adc64d0b7e39794a /net-im
parent34aa1e6a76363cb674119f8c99d143efc8f7e52a (diff)
downloadfreebsd-ports-gnome-dcb293d5bd3c35bc52899d2ee702bbec08222038.tar.gz
freebsd-ports-gnome-dcb293d5bd3c35bc52899d2ee702bbec08222038.tar.zst
freebsd-ports-gnome-dcb293d5bd3c35bc52899d2ee702bbec08222038.zip
Add libnice, a library and a transmitter that does ICE (as defined in the
ICE-19 draft), as well as Google Talk and MSN compatible ICE-like protocols.
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/libnice/Makefile29
-rw-r--r--net-im/libnice/distinfo3
-rw-r--r--net-im/libnice/files/patch-stun_md5.c10
-rw-r--r--net-im/libnice/files/patch-stun_sha1.c10
-rw-r--r--net-im/libnice/files/patch-stun_stunmessage.c10
-rw-r--r--net-im/libnice/files/patch-stun_tools_stund.c11
-rw-r--r--net-im/libnice/files/patch-stun_utils.h10
-rw-r--r--net-im/libnice/pkg-descr2
-rw-r--r--net-im/libnice/pkg-plist40
10 files changed, 126 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 155509292317..e21c023b8e1a 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -69,6 +69,7 @@
SUBDIR += libicq2000
SUBDIR += libjingle
SUBDIR += libmsn
+ SUBDIR += libnice
SUBDIR += libpurple
SUBDIR += libtelepathy
SUBDIR += libyahoo2
diff --git a/net-im/libnice/Makefile b/net-im/libnice/Makefile
new file mode 100644
index 000000000000..f0392f0f5458
--- /dev/null
+++ b/net-im/libnice/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libnice
+# Date created: 27 February 2009
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libnice
+PORTVERSION= 0.0.4
+CATEGORIES= net-im devel
+MASTER_SITES= http://nice.freedesktop.org/releases/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Library and transmitter that implements ICE-19
+
+WRKSRC= ${WRKDIR}/nice-${PORTVERSION}
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_GNOME= gnomehack pkgconfig glib20 ltverhack gnometarget
+USE_GSTREAMER= yes
+USE_AUTOTOOLS= libtool:15
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|__BYTE_ORDER|_BYTE_ORDER|g ; \
+ s|__BIG_ENDIAN|_BIG_ENDIAN|g' \
+ ${WRKSRC}/stun/md5.c \
+ ${WRKSRC}/stun/sha1.c
+
+.include <bsd.port.mk>
diff --git a/net-im/libnice/distinfo b/net-im/libnice/distinfo
new file mode 100644
index 000000000000..6442b3f10956
--- /dev/null
+++ b/net-im/libnice/distinfo
@@ -0,0 +1,3 @@
+MD5 (libnice-0.0.4.tar.gz) = 3a5a68cbc58a2f2d53d00e8c2cbb1f7a
+SHA256 (libnice-0.0.4.tar.gz) = eb16defe6e32356e193aa70daf8710e3d7617897eca0a065b41ad71b9fc70f4e
+SIZE (libnice-0.0.4.tar.gz) = 529834
diff --git a/net-im/libnice/files/patch-stun_md5.c b/net-im/libnice/files/patch-stun_md5.c
new file mode 100644
index 000000000000..8f787548f7ea
--- /dev/null
+++ b/net-im/libnice/files/patch-stun_md5.c
@@ -0,0 +1,10 @@
+--- stun/md5.c.orig 2009-02-27 23:04:31.000000000 -0500
++++ stun/md5.c 2009-02-27 23:05:15.000000000 -0500
+@@ -13,6 +13,7 @@
+ */
+
+ #include "md5.h"
++#include <sys/endian.h>
+ #include <string.h>
+
+ /* ===== start - public domain MD5 implementation ===== */
diff --git a/net-im/libnice/files/patch-stun_sha1.c b/net-im/libnice/files/patch-stun_sha1.c
new file mode 100644
index 000000000000..33e3775b2981
--- /dev/null
+++ b/net-im/libnice/files/patch-stun_sha1.c
@@ -0,0 +1,10 @@
+--- stun/sha1.c.orig 2009-02-27 23:05:24.000000000 -0500
++++ stun/sha1.c 2009-02-27 23:05:33.000000000 -0500
+@@ -13,6 +13,7 @@
+ */
+
+ #include "sha1.h"
++#include <sys/endian.h>
+ #include <string.h>
+
+
diff --git a/net-im/libnice/files/patch-stun_stunmessage.c b/net-im/libnice/files/patch-stun_stunmessage.c
new file mode 100644
index 000000000000..d8b2a3adfa45
--- /dev/null
+++ b/net-im/libnice/files/patch-stun_stunmessage.c
@@ -0,0 +1,10 @@
+--- stun/stunmessage.c.orig 2009-02-27 23:00:07.000000000 -0500
++++ stun/stunmessage.c 2009-02-27 23:00:27.000000000 -0500
+@@ -45,6 +45,7 @@
+ #else
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #endif
+
+
diff --git a/net-im/libnice/files/patch-stun_tools_stund.c b/net-im/libnice/files/patch-stun_tools_stund.c
new file mode 100644
index 000000000000..1e9fbb4ff7c2
--- /dev/null
+++ b/net-im/libnice/files/patch-stun_tools_stund.c
@@ -0,0 +1,11 @@
+--- stun/tools/stund.c.orig 2008-11-27 14:04:54.000000000 -0500
++++ stun/tools/stund.c 2009-02-27 23:15:29.000000000 -0500
+@@ -163,6 +163,8 @@ static int recv_err (int fd)
+ struct msghdr hdr;
+ memset (&hdr, 0, sizeof (hdr));
+ return recvmsg (fd, &hdr, MSG_ERRQUEUE) >= 0;
++#else
++ return -1;
+ #endif
+ }
+
diff --git a/net-im/libnice/files/patch-stun_utils.h b/net-im/libnice/files/patch-stun_utils.h
new file mode 100644
index 000000000000..189688d2c51e
--- /dev/null
+++ b/net-im/libnice/files/patch-stun_utils.h
@@ -0,0 +1,10 @@
+--- stun/utils.h.orig 2009-02-27 23:06:34.000000000 -0500
++++ stun/utils.h 2009-02-27 23:06:43.000000000 -0500
+@@ -49,6 +49,7 @@
+ #else
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <netinet/in.h>
+ #endif
+
+ # ifdef __cplusplus
diff --git a/net-im/libnice/pkg-descr b/net-im/libnice/pkg-descr
new file mode 100644
index 000000000000..93cfe2b5457e
--- /dev/null
+++ b/net-im/libnice/pkg-descr
@@ -0,0 +1,2 @@
+Libnice is a library and a transmitter that does ICE (as defined in the ICE-19
+draft), as well as Google Talk and MSN compatible ICE-like protocols.
diff --git a/net-im/libnice/pkg-plist b/net-im/libnice/pkg-plist
new file mode 100644
index 000000000000..b902b847104e
--- /dev/null
+++ b/net-im/libnice/pkg-plist
@@ -0,0 +1,40 @@
+bin/stunbdc
+bin/stund
+include/nice/address.h
+include/nice/agent.h
+include/nice/candidate.h
+include/nice/debug.h
+include/nice/nice.h
+include/nice/pseudossl.h
+include/nice/socket.h
+include/nice/socks5.h
+include/nice/tcp-bsd.h
+include/nice/tcp-turn.h
+include/nice/turn.h
+include/nice/udp-bsd.h
+lib/gstreamer-0.10/libgstnice.a
+lib/gstreamer-0.10/libgstnice.la
+lib/gstreamer-0.10/libgstnice.so
+lib/libnice.a
+lib/libnice.la
+lib/libnice.so
+lib/libnice.so.0
+libdata/pkgconfig/nice.pc
+share/gtk-doc/html/libnice/ch01.html
+share/gtk-doc/html/libnice/home.png
+share/gtk-doc/html/libnice/index.html
+share/gtk-doc/html/libnice/index.sgml
+share/gtk-doc/html/libnice/left.png
+share/gtk-doc/html/libnice/libnice-Debug-messages.html
+share/gtk-doc/html/libnice/libnice-NiceAddress.html
+share/gtk-doc/html/libnice/libnice-NiceAgent.html
+share/gtk-doc/html/libnice/libnice-NiceCandidate.html
+share/gtk-doc/html/libnice/libnice.devhelp
+share/gtk-doc/html/libnice/libnice.devhelp2
+share/gtk-doc/html/libnice/right.png
+share/gtk-doc/html/libnice/style.css
+share/gtk-doc/html/libnice/up.png
+@dirrm share/gtk-doc/html/libnice
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrm include/nice