aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2009-08-04 04:35:54 +0800
committeraraujo <araujo@FreeBSD.org>2009-08-04 04:35:54 +0800
commite055a5948ba51444bdd3d0a6213555780bfab699 (patch)
treeeaf98d75946eccbc268ebf2d1bffb246598310d9 /net-im
parent309f6cde63888344bfeb98990c9f3eb484a9a1d9 (diff)
downloadfreebsd-ports-gnome-e055a5948ba51444bdd3d0a6213555780bfab699.tar.gz
freebsd-ports-gnome-e055a5948ba51444bdd3d0a6213555780bfab699.tar.zst
freebsd-ports-gnome-e055a5948ba51444bdd3d0a6213555780bfab699.zip
- Fix the issue when you set a custom PREFIX or LOCALBASE.
PR: ports/137229 Submitted by: Sylvio Cesar <scjamorim@bsd.com.br> (maintainer)
Diffstat (limited to 'net-im')
-rw-r--r--net-im/amsn/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/net-im/amsn/Makefile b/net-im/amsn/Makefile
index 53aa3a9ed7be..710ab574a7fa 100644
--- a/net-im/amsn/Makefile
+++ b/net-im/amsn/Makefile
@@ -22,14 +22,26 @@ RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84 \
${LOCALBASE}/lib/tls/tls.tcl:${PORTSDIR}/devel/tcltls \
dtplite:${PORTSDIR}/devel/tcllib
-GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
--with-tk=${LOCALBASE}/lib/tk8.4
-CONFIGURE_ENV= TK_INC_SPEC=${LOCALBASE}/include/tk8.4/generic
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ TK_INC_SPEC=${LOCALBASE}/include/tk8.4/generic
+
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+PLIST_SUB+= NLS=""
+.endif
post-patch:
@${FIND} ${WRKSRC} -name '*.c' -or -name '*.h' | ${XARGS} ${REINPLACE_CMD} -e 's| ||'