aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authorfeld <feld@FreeBSD.org>2017-10-23 21:19:35 +0800
committerfeld <feld@FreeBSD.org>2017-10-23 21:19:35 +0800
commit0e6ba4f9bf91c2beb71199a4924b8b30e959b4b6 (patch)
treed28d164eb401a21a8188c104fc1dcbf403dc0b61 /net-im
parent601ccda270e92d1ddd9504c784acb398fdd749cc (diff)
downloadfreebsd-ports-gnome-0e6ba4f9bf91c2beb71199a4924b8b30e959b4b6.tar.gz
freebsd-ports-gnome-0e6ba4f9bf91c2beb71199a4924b8b30e959b4b6.tar.zst
freebsd-ports-gnome-0e6ba4f9bf91c2beb71199a4924b8b30e959b4b6.zip
net-im/py-matrix-synapse: Update to 0.24.0
Changelog: https://github.com/matrix-org/synapse/releases/tag/v0.24.0
Diffstat (limited to 'net-im')
-rw-r--r--net-im/py-matrix-synapse/Makefile2
-rw-r--r--net-im/py-matrix-synapse/distinfo6
-rw-r--r--net-im/py-matrix-synapse/files/patch-disable-affinity114
3 files changed, 4 insertions, 118 deletions
diff --git a/net-im/py-matrix-synapse/Makefile b/net-im/py-matrix-synapse/Makefile
index c670d88fe31e..6cc148ab0e56 100644
--- a/net-im/py-matrix-synapse/Makefile
+++ b/net-im/py-matrix-synapse/Makefile
@@ -3,7 +3,7 @@
PORTNAME= matrix-synapse
DISTVERSIONPREFIX= v
-DISTVERSION= 0.23.0
+DISTVERSION= 0.24.0
PORTREVISION= 0
CATEGORIES= net-im python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/net-im/py-matrix-synapse/distinfo b/net-im/py-matrix-synapse/distinfo
index d462fc022c8e..b5cb81f0c416 100644
--- a/net-im/py-matrix-synapse/distinfo
+++ b/net-im/py-matrix-synapse/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1506956682
-SHA256 (matrix-org-synapse-v0.23.0_GH0.tar.gz) = 26a4bae1097d097452d53a89bcb72b61eafc006d50f030b84eba8e39d9454a2e
-SIZE (matrix-org-synapse-v0.23.0_GH0.tar.gz) = 846883
+TIMESTAMP = 1508763796
+SHA256 (matrix-org-synapse-v0.24.0_GH0.tar.gz) = c8153a383348760d060b21d8f643c440677bff80df5ddffaafdf2e0e8d4cd4e3
+SIZE (matrix-org-synapse-v0.24.0_GH0.tar.gz) = 877263
diff --git a/net-im/py-matrix-synapse/files/patch-disable-affinity b/net-im/py-matrix-synapse/files/patch-disable-affinity
deleted file mode 100644
index 788d0f0c1be6..000000000000
--- a/net-im/py-matrix-synapse/files/patch-disable-affinity
+++ /dev/null
@@ -1,114 +0,0 @@
---- synapse/app/_base.py.orig 2017-10-02 12:52:03 UTC
-+++ synapse/app/_base.py
-@@ -15,7 +15,6 @@
- import gc
- import logging
-
--import affinity
- from daemonize import Daemonize
- from synapse.util import PreserveLoggingContext
- from synapse.util.rlimit import change_resource_limit
-@@ -41,8 +40,7 @@ def start_worker_reactor(appname, config
- config.gc_thresholds,
- config.worker_pid_file,
- config.worker_daemonize,
-- config.worker_cpu_affinity,
-- logger,
-+ logger
- )
-
-
-@@ -52,7 +50,6 @@ def start_reactor(
- gc_thresholds,
- pid_file,
- daemonize,
-- cpu_affinity,
- logger,
- ):
- """ Run the reactor in the main process
-@@ -66,7 +63,6 @@ def start_reactor(
- gc_thresholds:
- pid_file (str): name of pid file to write to if daemonize is True
- daemonize (bool): true to run the reactor in a background process
-- cpu_affinity (int|None): cpu affinity mask
- logger (logging.Logger): logger instance to pass to Daemonize
- """
-
-@@ -77,9 +73,6 @@ def start_reactor(
- # between the sentinel and `run` logcontexts.
- with PreserveLoggingContext():
- logger.info("Running")
-- if cpu_affinity is not None:
-- logger.info("Setting CPU affinity to %s" % cpu_affinity)
-- affinity.set_process_affinity_mask(0, cpu_affinity)
- change_resource_limit(soft_file_limit)
- if gc_thresholds:
- gc.set_threshold(*gc_thresholds)
---- synapse/app/homeserver.py.orig 2017-10-02 12:52:03 UTC
-+++ synapse/app/homeserver.py
-@@ -442,7 +442,6 @@ def run(hs):
- hs.config.gc_thresholds,
- hs.config.pid_file,
- hs.config.daemonize,
-- hs.config.cpu_affinity,
- logger,
- )
-
---- synapse/config/server.py.orig 2017-10-02 12:52:03 UTC
-+++ synapse/config/server.py
-@@ -30,7 +30,6 @@ class ServerConfig(Config):
- self.user_agent_suffix = config.get("user_agent_suffix")
- self.use_frozen_dicts = config.get("use_frozen_dicts", False)
- self.public_baseurl = config.get("public_baseurl")
-- self.cpu_affinity = config.get("cpu_affinity")
-
- # Whether to send federation traffic out in this process. This only
- # applies to some federation traffic, and so shouldn't be used to
-@@ -155,27 +154,6 @@ class ServerConfig(Config):
- # When running as a daemon, the file to store the pid in
- pid_file: %(pid_file)s
-
-- # CPU affinity mask. Setting this restricts the CPUs on which the
-- # process will be scheduled. It is represented as a bitmask, with the
-- # lowest order bit corresponding to the first logical CPU and the
-- # highest order bit corresponding to the last logical CPU. Not all CPUs
-- # may exist on a given system but a mask may specify more CPUs than are
-- # present.
-- #
-- # For example:
-- # 0x00000001 is processor #0,
-- # 0x00000003 is processors #0 and #1,
-- # 0xFFFFFFFF is all processors (#0 through #31).
-- #
-- # Pinning a Python process to a single CPU is desirable, because Python
-- # is inherently single-threaded due to the GIL, and can suffer a
-- # 30-40%% slowdown due to cache blow-out and thread context switching
-- # if the scheduler happens to schedule the underlying threads across
-- # different cores. See
-- # https://www.mirantis.com/blog/improve-performance-python-programs-restricting-single-cpu/.
-- #
-- # cpu_affinity: 0xFFFFFFFF
--
- # Whether to serve a web client from the HTTP/HTTPS root resource.
- web_client: True
-
---- synapse/config/workers.py.orig 2017-10-02 12:52:03 UTC
-+++ synapse/config/workers.py
-@@ -33,7 +33,6 @@ class WorkerConfig(Config):
- self.worker_name = config.get("worker_name", self.worker_app)
-
- self.worker_main_http_uri = config.get("worker_main_http_uri", None)
-- self.worker_cpu_affinity = config.get("worker_cpu_affinity")
-
- if self.worker_listeners:
- for listener in self.worker_listeners:
---- synapse/python_dependencies.py.orig 2017-10-02 12:52:03 UTC
-+++ synapse/python_dependencies.py
-@@ -40,7 +40,6 @@ REQUIREMENTS = {
- "pymacaroons-pynacl": ["pymacaroons"],
- "msgpack-python>=0.3.0": ["msgpack"],
- "phonenumbers>=8.2.0": ["phonenumbers"],
-- "affinity": ["affinity"],
- }
- CONDITIONAL_REQUIREMENTS = {
- "web_client": {