aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2018-12-15 12:55:05 +0800
committeryuri <yuri@FreeBSD.org>2018-12-15 12:55:05 +0800
commit9ceeca264c722006da17ae43d83d324a57800950 (patch)
tree9e0cf0bffcf3599035e0b849f27264190621ec76 /net-im
parent9dc82f28aa3d303461a022cde3ccf53ec64e4adb (diff)
downloadfreebsd-ports-gnome-9ceeca264c722006da17ae43d83d324a57800950.tar.gz
freebsd-ports-gnome-9ceeca264c722006da17ae43d83d324a57800950.tar.zst
freebsd-ports-gnome-9ceeca264c722006da17ae43d83d324a57800950.zip
New port: net-im/ssh-chat: Chat over SSH
Diffstat (limited to 'net-im')
-rw-r--r--net-im/Makefile1
-rw-r--r--net-im/ssh-chat/Makefile37
-rw-r--r--net-im/ssh-chat/distinfo15
-rw-r--r--net-im/ssh-chat/pkg-descr3
4 files changed, 56 insertions, 0 deletions
diff --git a/net-im/Makefile b/net-im/Makefile
index 2a0f1510a981..9f7d599a62d0 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -178,6 +178,7 @@
SUBDIR += skype-devel
SUBDIR += skype4
SUBDIR += slack-term
+ SUBDIR += ssh-chat
SUBDIR += talkatu
SUBDIR += teamwords
SUBDIR += telegram
diff --git a/net-im/ssh-chat/Makefile b/net-im/ssh-chat/Makefile
new file mode 100644
index 000000000000..63be2659dfba
--- /dev/null
+++ b/net-im/ssh-chat/Makefile
@@ -0,0 +1,37 @@
+# $FreeBSD$
+
+PORTNAME= ssh-chat
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.7-4
+DISTVERSIONSUFFIX= -gf36d7eb
+CATEGORIES= net-im
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Chat over SSH
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/LICENSE
+
+BUILD_DEPENDS= go:lang/go
+
+USE_GITHUB= nodefault # the main code is in GH_TUPLE
+GH_ACCOUNT= shazow
+GH_TUPLE= shazow:ssh-chat:${DISTVERSIONFULL}:main/src/github.com/shazow/ssh-chat \
+ shazow:rateio:e8e0088:rateio/src/github.com/shazow/rateio \
+ alexcesaro:log:61e6862:log/src/github.com/alexcesaro/log \
+ howeyc:gopass:bf9dde6:gopass/src/github.com/howeyc/gopass \
+ jessevdk:go-flags:c6ca198:flags/src/github.com/jessevdk/go-flags \
+ golang:crypto:c126467:crypto/src/golang.org/x/crypto \
+ golang:sys:ac767d6:sys/src/golang.org/x/sys
+GH_SUBDIR= src/github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME} && \
+ ${SETENV} ${MAKE_ENV} GOPATH=${WRKSRC} go install ./...
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net-im/ssh-chat/distinfo b/net-im/ssh-chat/distinfo
new file mode 100644
index 000000000000..8db9db914f3e
--- /dev/null
+++ b/net-im/ssh-chat/distinfo
@@ -0,0 +1,15 @@
+TIMESTAMP = 1544849393
+SHA256 (shazow-ssh-chat-v1.7-4-gf36d7eb_GH0.tar.gz) = bef55195517606c2f11af09c3ad735cf057da8449bcf3eabcd97f0424e9b9d96
+SIZE (shazow-ssh-chat-v1.7-4-gf36d7eb_GH0.tar.gz) = 34661
+SHA256 (shazow-rateio-e8e0088_GH0.tar.gz) = 75fa928cb0b3445a94d5ef05b15ab67ac7f5c2a8a5617e4b829bcc27ef4c0eba
+SIZE (shazow-rateio-e8e0088_GH0.tar.gz) = 2528
+SHA256 (alexcesaro-log-61e6862_GH0.tar.gz) = 75e35a9d70ada8d32a43f37aecc47a1a67305547658a6a86054ceca87bb9a263
+SIZE (alexcesaro-log-61e6862_GH0.tar.gz) = 8800
+SHA256 (howeyc-gopass-bf9dde6_GH0.tar.gz) = 365806397c1f279fbb45b86562c43e6f112e8a81cf788df5ea356a18c80f6537
+SIZE (howeyc-gopass-bf9dde6_GH0.tar.gz) = 11287
+SHA256 (jessevdk-go-flags-c6ca198_GH0.tar.gz) = 7985a6a45b8dd2de04a7e295f562a5589801076c265baea39c7ea51410db4489
+SIZE (jessevdk-go-flags-c6ca198_GH0.tar.gz) = 55457
+SHA256 (golang-crypto-c126467_GH0.tar.gz) = af4ccc970d8ad62b042a0dcfa54d00c3b059840e61cd9023b059f848964b7b17
+SIZE (golang-crypto-c126467_GH0.tar.gz) = 1624160
+SHA256 (golang-sys-ac767d6_GH0.tar.gz) = 8cfe5e75d7d145302d18a41938c0c0c18d82644de0a753b7b503efe3071258dd
+SIZE (golang-sys-ac767d6_GH0.tar.gz) = 980197
diff --git a/net-im/ssh-chat/pkg-descr b/net-im/ssh-chat/pkg-descr
new file mode 100644
index 000000000000..87b3fe95f0fb
--- /dev/null
+++ b/net-im/ssh-chat/pkg-descr
@@ -0,0 +1,3 @@
+Custom SSH server written in Go. Instead of a shell, you get a chat prompt.
+
+WWW: https://github.com/shazow/ssh-chat