aboutsummaryrefslogtreecommitdiffstats
path: root/net-im
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2014-02-05 14:50:43 +0800
committerdinoex <dinoex@FreeBSD.org>2014-02-05 14:50:43 +0800
commit082cfd177c17216932c98d0fd9499a2962ea2eb4 (patch)
tree4483938f1d6a90ea73459599e356bb5ac87be755 /net-im
parent887beb16290d5f21d26a4dfe0d746a8752585a5a (diff)
downloadfreebsd-ports-gnome-082cfd177c17216932c98d0fd9499a2962ea2eb4.tar.gz
freebsd-ports-gnome-082cfd177c17216932c98d0fd9499a2962ea2eb4.tar.zst
freebsd-ports-gnome-082cfd177c17216932c98d0fd9499a2962ea2eb4.zip
- fix build with clang
PR: 186389 Submitted by: Tijl Coosemans
Diffstat (limited to 'net-im')
-rw-r--r--net-im/licq/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/net-im/licq/Makefile b/net-im/licq/Makefile
index dcbf408425c7..62f938844ee0 100644
--- a/net-im/licq/Makefile
+++ b/net-im/licq/Makefile
@@ -14,7 +14,6 @@ LIB_DEPENDS= libboost_regex.so:${PORTSDIR}/devel/boost-libs
LICENSE= GPLv2
-USE_GCC= yes
USES= cmake iconv
WRKSRC= ${WRKDIR}/${DISTNAME}
LICQ_PORT?= net-im/licq
@@ -23,7 +22,7 @@ LICQ_PORT?= net-im/licq
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib ${ICONV_LIB} -Wl,--export-dynamic
CPPFLAGS+= -I${LOCALBASE}/include
CFLAGS+= -I${LOCALBASE}/include
-CXXFLAGS+= -Wl,--export-dynamic
+CXXFLAGS+= -Wl,--export-dynamic -DGTEST_USE_OWN_TR1_TUPLE
OPTIONS_DEFINE= OPENSSL
OPTIONS_DEFAULT=OPENSSL